LiteSpeed Web Server 4.1.5 released

Discussion in 'News' started by mistwang, Oct 7, 2011.

Thread Status:
Not open for further replies.
  1. mistwang

    mistwang LiteSpeed Staff

    This is the latest stable release of 4.1 with minor bug fixes of 4.1.4.

    One commonly requested feature from Apache suphp user has been implemented. LSWS by default does not serve scripts with unsafe file permission (group and world writable), or the script is inside a directory with unsafe permissions (group and world writable). This behavior can be controlled with two new configuration entries under "Server"->"Security" tab, "Script Restricted Permission Mask" and "Script Restricted Directory Permission Mask". default value for both is "022", if you want to disable this security feature set both of them to "000".

    All users on previous 4.1 versions are recommended to upgrade to this one.



    Download LiteSpeed Web Server
    View Version History
  2. mistwang

    mistwang LiteSpeed Staff

    4.1.5 package has been updated to disable the new security feature, default for "Script Restricted Permission Mask" and "Script Restricted Directory Permission Mask" has been changed to "000".

    You need to manually enable it if you want it.
Thread Status:
Not open for further replies.

Share This Page