litespeed with rvm gemset?

Discussion in 'Ruby/Rails' started by nikss, Jan 31, 2014.

  1. nikss

    nikss New Member

    Is it possible to run rails 4 under the rvm gemset with litespeed?
    I stick to new manual and tried with ruby-lsapi
    from rubygems
    manually compiled

    When i setup Rack/Rails Settings Ruby Path as:

    1./usr/local/rvm/rubies/ruby-1.9.3-p392/bin/ruby
    i got in stderr.log:
    /usr/local/rvm/rubies/ruby-1.9.3-p392/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- rack (LoadError)

    obviously gemset environemnt not loaded, paths etc.

    2./usr/local/rvm/wrappers/ruby-1.9.3-p392@sys_admin/ruby
    i got in stderr.log:
    /usr/local/rvm/gems/ruby-1.9.3-p392@sys_admin/gems/activesupport-4.0.0/lib/active_support/dependencies.rb:228:in `require': wrong argument type LSAPI (expected File) (TypeError)

    well here env variables f.e.
    GEM_PATH
    are setup properly but its not working

    what am i doing wrong?
    app works with passenger standalone/apache/nginx

Share This Page