Litespeed won't connect to MySQL! Please help! Will Pay!

Discussion in 'Install/Configuration' started by koin, Mar 17, 2010.

  1. koin

    koin New Member

    litespeed

    edited for google no need purposes
    Last edited: Feb 28, 2011
  2. NiteWave

    NiteWave Administrator

    check mysql.default_socket in php.ini, if it matches with mysqld process.

    for example, in one of test boxes,
    Code:
    ~>ps -ef|grep mysql
    ...
    mysql     2334  2287  0 Jan31 ?        00:16:35 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --socket=/var/lib/mysql/mysql.sock
    ...
    /usr/local/lsws/fcgi-bin>./lsphp5 -i|grep default_socket
    ...
    mysql.default_socket => /var/lib/mysql/mysql.sock => /var/lib/mysql/mysql.sock
    ...
    they matches: both pointing to /var/lib/mysql/mysql.sock
  3. koin

    koin New Member

    not really understanding what you're saying but I looked in my php.ini file and found where the mysql socket would go but I couldn't figure out what to modify

    if someone could give me some insight I'd appreciate it

    litespeed is not connecting to SQL.
  4. NiteWave

    NiteWave Administrator

    what's the output on your server?

    Code:
    $ps -ef|grep mysql
    and
    Code:
    #/path/to/lsws/fcgi-bin/lsphp5 -i|grep default_socket
  5. koin

    koin New Member

    -bash: lsws-4.0.13/fcgi-bin/lsphp5: No such file or directory


    (I looked inside fcgi-bin and I don't have an lsphp5 directory)

    I've been told I need to recompile php, is that my issue?
  6. NiteWave

    NiteWave Administrator

    lsphp5 is a file not a directory.
    where lsws installed in your server?
  7. koin

    koin New Member

    It just occurred to me that litespeed has a compile PHP option in the admin console..I'm currently building PHP thru that, I'll keep you posted (something tells me this won't help because I have terrible luck)

    litespeed is @ /lsws-4.0.13/ on my box
  8. koin

    koin New Member

    Okay, I compiled PHP and now I have a new error in my browser when I try to load the site:

    Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    Any ideas?
  9. NiteWave

    NiteWave Administrator

    check if lsphp5 is built with this option:
    --with-mysql
  10. koin

    koin New Member

    did I do that right?
  11. NiteWave

    NiteWave Administrator

    No. when you compile the PHP, need "Configure Parameters", it should include "--with-mysql". the default one may be
    Code:
    --with-mysqli --with-zlib --with-gd --enable-shmop --enable-track-vars --enable-sockets --enable-sysvsem --enable-sysvshm --enable-magic-quotes --enable-mbstring --with-iconv
    add "--with-mysql", now become to
    Code:
    --with-mysql --with-mysqli --with-zlib --with-gd --enable-shmop --enable-track-vars --enable-sockets --enable-sysvsem --enable-sysvshm --enable-magic-quotes --enable-mbstring --with-iconv
  12. koin

    koin New Member

    Ohh okay, doing that now.
  13. oviliz

    oviliz New Member

    I have same WordPress problem / message.

    I run that configuration but she give me this error:

    Some idea?


  14. NiteWave

    NiteWave Administrator

    please find the detail error message which is in the lower part of the same PHP build page.

Share This Page