lshttpd 2.2.2 doesn't start on FreeBSD6.1

Discussion in 'Install/Configuration' started by Tex, Oct 5, 2006.

  1. Tex

    Tex New Member

    Hi,

    I downloaded the FreeBSD 6.1 compile through the URL found in another post and installed it. Installation was smooth but at the end :

    At this point, the only running process is "lscgid". I killed and restarted with a debugLevel of 50, nothing better except a few more lines in the error log :

    Any help ?
  2. xing

    xing LiteSpeed Staff

    Is litespeed is configured to listen to port 80, you need root or sudo priviledges to start the service.

    We tested the installation on our clean FreeBSD 6.1 vmware image and cannot duplicate the problem.

    What options did you select during the install? Retry installation with basic config parameters.

    Here is the FreeBSD6 2.2.2 standard package:

    http://www.litespeedtech.com/packages/2.2/std/lsws-2.2.2-std-i386-freebsd6.tar.gz
  3. Tex

    Tex New Member

    Here is the full installation procedure I replayed (FreeBSD 6.1 amd64 with 32 bits lib), all with default settings ... :

  4. mistwang

    mistwang LiteSpeed Staff

    Looks like something wrong with the IP address detection, the 32bit compatible layer of amd64 may not be complete.
    Can you try the linux binary instead? FreeBSD has a linux ABI compatible layer.
  5. Tex

    Tex New Member

    The Linux binary on the same server works ... at least it starts, I didn't made more testing. I have Linux server to run Linux binaries ;)

    Would be nice to be able to run the native FreeBSD binary on FreeBSD at it looks you support this OS.

    Thanks.
  6. mistwang

    mistwang LiteSpeed Staff

    Eventually, there will be a native FreeBSD AMD64 release. :)

Share This Page