lsphp permissions

Discussion in 'Install/Configuration' started by dirtymafia, Jul 26, 2011.

  1. dirtymafia

    dirtymafia New Member

    New installation, using litespeed admin UI to compile php 5.3.5. Using PHP_SuEXEC. This worked fine for the first few compiles, but now compiling causes 403 Service unavailable when trying to run php files. I can fix the problem by going to /usr/local/lsws/fcgi-bin and chmod o+rx lsphp-5.3.5.

    Is there a reason I just now how to start doing this? I have been using php_suexec from the begging but had to compile php with mycrypt support, that is when it stopped working without chmod'ing lsphp-5.3.5 everytime i re-compile.
  2. mistwang

    mistwang LiteSpeed Staff

    I think it is your "umask" setting for root user changed from 0022 to 0027
    We will update our script to set the permission right.
  3. dirtymafia

    dirtymafia New Member

    Ahh, very good thinking. I did change the default umask. Is there a file i can edit that will change the scripts that run to add this chmod in there until you fix it.

    By this I mean some sort of template file the build scripts are built off of? If there is one.
    Last edited: Jul 26, 2011
  4. webizen

    webizen New Member

    you may add a line (in bold) in /path/to/lsws/admin/html/utility/build_php/build_install.template as follows:

Share This Page