LSW 4.0 upgraded failed CentOS 64 bits

Discussion in 'General' started by fastproxy, Mar 21, 2009.

  1. fastproxy

    fastproxy New Member

    Hi,

    I just manually upgraded to LSW 4.0 and the webserver could not start.

    So i have to get back to 3.4 for now.

    Please check the issue with 64 bit OS
  2. anewday

    anewday Moderator

    Need to give more info to debug.
  3. Tony

    Tony Member

    The majority of our machines run CentOS 5 64bit. Are you sure it's a problem specific to 64bit operating systems and not something else?
  4. fastproxy

    fastproxy New Member

    I just upgrade LSWS like normal: download unzip, install (completed), restart and it does not start or pump out any error.

    I go back to old version then it works.

    Not sure what else is need to get it running. Not sure where is the log to look for.
  5. mistwang

    mistwang LiteSpeed Staff

    Maybe something wrong with processing your Apache httpd.conf, maybe you should pack your httpd.conf and include files and send it to us.
  6. fastproxy

    fastproxy New Member

    I just tried with another CentOS 5.2 32 bits and the same problem happens.
    The upgrade went fine but when attempt to restart, even though it says LSWS restarted but actually LSWS is down.

    The version 4.0b3 works fine though.

    Here is how i upgrade:
    - Download source and unzip
    - copy serial.no key from old LSWS folder to LSWS 4.0 folder
    - run install.sh choose upgrade
    - Everything went fine( using default config)
    - Then restart LSWS
    -> does not start ( eventhough it says it starts)

    I am running LSWS with apache config though
  7. mistwang

    mistwang LiteSpeed Staff

    try

    ./lshttpd.4.0.dbg -d

    from command line, if it crashed, send us the core file.
  8. fastproxy

    fastproxy New Member

    okie, Please be more specific.

    When should i run that command? After installation?

    Btw, i dont have such file, but i do have: lshttpd.dbg.4.0b3

    Where is the core file located?
  9. mistwang

    mistwang LiteSpeed Staff

    under /usr/local/lsws/bin/ or /opt/lsws/bin, do

    ./lshttpd.dbg.4.0 -d

    You have to install 4.0 first.

    core file will either under /tmp/lshttpd/bak_cores/ or current directory.
  10. mistwang

    mistwang LiteSpeed Staff

    Please try 4.0.1 release package, just change the version number in the download link.
    Fixed a bug that affect some plesk user, maybe related.
  11. anewday

    anewday Moderator

    What other changes/fixes are in 4.0.1 ?

Share This Page