Magento - Litespeed - SOAP Request Not Completing

Discussion in 'PHP' started by mphillips, Aug 9, 2010.

  1. mphillips

    mphillips New Member

    I am running Magento on Litespeed 4.0.6 with PHP 5.2.4 and am having some trouble with a soap request. It seems that requests that take more than 10 or so seconds fail to complete. The requests what complete seem to take only a few seconds.

    Here is what the litespeed logs say:

    2010-08-02 09:58:58.946 [INFO] [123.123.123.123:47089-1#store.test.com] connection to [uds://tmp/lshttpd/store.test.com-lsphp.sock] on request #2, confirmed: 1, Connection reset by peer!
    2010-08-02 09:58:59.214 [NOTICE] [123.123.123.123:47089-1#store.test.com] [uds://tmp/lshttpd/store.test.com-lsphp.sock] Request in process stage, fail with 503

    DEBUG log:
    2010-08-09 11:45:47.549 [DEBUG] [123.123.123.123:61457-0#store.test.com] run lsapi processor.
    2010-08-09 11:45:47.549 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] request header is done
    2010-08-09 11:45:47.549 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] ExtConn::continueRead()
    2010-08-09 11:45:47.549 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] Request body done!
    2010-08-09 11:45:47.549 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] ExtConn::suspendWrite()
    2010-08-09 11:45:47.549 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] processNewReq() return 0.
    2010-08-09 11:45:47.550 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] ExtConn::eek:nRead()
    2010-08-09 11:45:47.550 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] LsapiConn::doRead()
    2010-08-09 11:45:47.550 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] process packet header 8 bytes
    2010-08-09 11:45:47.550 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] process packet header 0 bytes
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] ExtConn::eek:nRead()
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] LsapiConn::doRead()
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] process packet header 8 bytes
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] process response header 71 bytes
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] response header finished!
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] GZIP response body!
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] setupGzipBuf() begin GZIP stream.
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] process packet header 8 bytes
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] process response stream 561 bytes, packet left: 553
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] HttpExtConnector::processRespBodyData()
    2010-08-09 11:45:52.307 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] process packet header 8 bytes
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] [EXT] EndResponse( endCode=0, protocolStatus=0 )
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] release ExtProcessor!
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] endDynResp() end GZIP stream.
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] Written to client: 601
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] writeRespBody() return 341
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] ReqBody: 0, RespBody: 341, HEC_COMPLETE!
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] m_pHandler->onWrite() return 0
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] HttpConnection::flush()!
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] HttpConnection::nextRequest()!
    2010-08-09 11:45:52.308 [DEBUG] [123.123.123.123:61457-0#store.test.com:lsapi] HttpExtConnector::cleanUp() ...
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] HttpIOLink::handleEvents() events=1!
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] HttpConnection::eek:nReadEx(), state: 0!
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] readToHeaderBuf().
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] End of stream detected, CLOSING!
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] Read from client: -1
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] readToHeaderBuf() return 0.
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] Shutting down out-bound socket ...
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] HttpIOLink::handleEvents() events=17!
    2010-08-09 11:45:57.182 [DEBUG] [123.123.123.123:61457-1] Close socket ...

    It looks like all of the litespeed and php timeout and memory settings are set correctly so I am not sure what could be causing this.

    Does anyone have any experience with this and could help point me in the right direction?

    Thanks for your help!
  2. NiteWave

    NiteWave Administrator

    if it's lsws 4.0.6, can you upgrade to latest 4.0.15/16. since there is a security issue on 4.0.14 and below. also considering upgrade php to 5.2.14? see if the issue still there.

Share This Page