Method not allowed with POST

Discussion in 'PHP' started by spectre73, Dec 7, 2006.

  1. spectre73

    spectre73 New Member

    I get "Method not allowed" when i try a POST method in a web form that is made with Coffeecup form builder 5.5

    I compiled the PHP 4/5 Universal Module 2.3 with PHP 5.2.0 and everything is installed ok but i did not change anything in the litespeed configuration to handle php scripts or the POST method

    Anyone can guide me to make it work ?

    Thanks
  2. xing

    xing LiteSpeed Staff

    Are you getting this as an php error or litespeed error?

    Most likely your form html is invalid. Please post your html form.
  3. spectre73

    spectre73 New Member

    A litespeed error....

    Well if you can tell me how to enable the POST method in litespeed it would be appreciated....
  4. xing

    xing LiteSpeed Staff

    POST method is enabled. There is no way to disable it.

    You need to enable "debug logging", via "Service Manager", test the broken url, and send us the relevant log entries.

    I don't think it was a POST method that broke.
  5. xing

    xing LiteSpeed Staff

    Make sure your form html contains "action" attribute pointing to the php file.

    From the error log, it looks like your have broken html causing the web browser to submit a POST request to a static file which for security reasons is not allowed in litespeed.
  6. spectre73

    spectre73 New Member

    Well the coffeecup software is rather odd on making forms....is there an email that i can send you the 4 files so you can check them ?

    Thanks


  7. xing

    xing LiteSpeed Staff

    If you post the relevant, <form>*</form>, entries someone in the forum can check it out and point out your error.

    To be honest, this is really not the correct place for html coding help. I would first highly recommend you to go a google check for "html form tag syntax" and pay attention to the "action" attribute.
  8. mistwang

    mistwang LiteSpeed Staff

    I think your PHP configuration is not right, *.php is treated as static file, so POST is not allowed, check your lsphp external app and script handler configuration, pay attention to the error/warning message when LSWS starts.
  9. spectre73

    spectre73 New Member

    Can you give me a step by step list that i can check with the most details possible ?

    Thanks


  10. mistwang

    mistwang LiteSpeed Staff

    try to access any PHP script, see if it works. If not, reinstall you server with php support enabled during installation. check you PHP script again. Replace lsws/fcgi-bin/lsphp with your own PHP binary, restart server, check PHP script again.
    If everything works, try your POST test, if not, check error.log, stderr.log see if there is any clue.
  11. spectre73

    spectre73 New Member

    How do i enable php support during installation ?


  12. mistwang

    mistwang LiteSpeed Staff

    run install.sh, you will know.
  13. spectre73

    spectre73 New Member

    I got it working....i have gone to your online demo and copied the 2 sections concerning php and restarted litespeed and it worked.


  14. spectre73

    spectre73 New Member

    By default this configuration should be included in the default install....
  15. mistwang

    mistwang LiteSpeed Staff

    Yes, they are. You probably did not enable PHP support during the installation.
  16. spectre73

    spectre73 New Member


    Well i tried reinstalling it and the only option it gave me was to enable php acceleration or not....it did not ask me to put php support....maybe it's because it is the free version....
  17. mistwang

    mistwang LiteSpeed Staff

    The install script should prompt:
    Code:
    Setup up PHP [Y/n]:
    Default is yes. It should be enabled unless you select "n".
    Please make sure to select "Reinstall" when you run the install.sh, "Upgrade" will not show that option.
  18. spectre73

    spectre73 New Member

    Could you please delete this Thread it has been resolved a long time ago.... ?


  19. mistwang

    mistwang LiteSpeed Staff

    We will leave it as it might be helpful for others who have the similar issue.

Share This Page