Missing script handler for suffix '.php', access denied!

Discussion in 'Install/Configuration' started by ts77, Mar 31, 2005.

  1. ts77

    ts77 New Member

    Ok, here is another one.
    I guess I did something wrong in the configuration thats why I post it in this forum.

    I'm getting this error-message for all requests to a given virtual host on my server. Other vhosts are working fine and also with php-files.
    I didn't setup anything related to the fastcgi-handlers dependend on the virtual host. Thats why I find this behaviour a little bit irritating.

    That is the full error-message:
    Code:
    2005-03-31 19:41:21.423 [ERROR] [] Missing script handler for suffix '.php', access denied!
    2005-03-31 19:41:21.423 [INFO] [] Content len: 0, Request line:
    GET /archiv.php HTTP/1.1
    
    That server is running lsws 2.0.0.

    I would appreciate any ideas about that.


    thomas
  2. mistwang

    mistwang LiteSpeed Staff

    Only possible reason I could think of is that the MIME setting has been overriden some where, at context level or in a .htaccess file.

    The problem cannot be fixed by adding an explicit script handler?
  3. ts77

    ts77 New Member

    Damned, I thought there was no .htaccess but there was a forgotton one with:
    AddType application/x-httpd-php .html .htm

    could this have caused this strange behaviour? would it override the script-handler or something?
    for apache it *adds* them to the existing handlers.

    I didn't need that so I just removed it and it started to work again.

    Thanks for your support!
  4. mistwang

    mistwang LiteSpeed Staff

    You are welcome. :)

    That should not affect ".php", could be a bug, I will take a look.
    It not easy to support Apache style MIME setting and .htaccess in much efficient manner. ;-)

    Thanks.
  5. mistwang

    mistwang LiteSpeed Staff

    It is a bug, fixed. Please download 2.0.2 again if you want.
  6. ts77

    ts77 New Member

    Yeah, that worked. I can confirm that .

    Thanks for your fast bugfixes :).

Share This Page