MySQL client ran out of memory

Discussion in 'PHP' started by amcd, Jul 10, 2006.

  1. amcd

    amcd New Member

    i successfully install lsws on my the webserver for my forums and i must say it looks faster already, without any tuning

    but there is one problem which i just cant figure out

    when the 'user promotions' scheduled task runs, it generates an error


    php is running with lsapi. the default installation had mysql 3.xx which was not good enough so i compiled my own php as per instructions in the wiki

    php ver 4.4.2
    mysql is running on a separate server - ver 4.1.16-standard
    client as per phpinfo - Client API version 4.1.19

    if any other information is needed please ask

    edit:
    P.S.: everytime this error is generated, one line is added to /usr/local/lsws/logs/stderr.log - 'Out of memory (Needed 293404 bytes)' - the number of bytes fluctuates between 290000 and 400000
    Last edited: Jul 10, 2006
  2. mistwang

    mistwang LiteSpeed Staff

    Looks like you need to increase the memory limit at the bottom of your phpLsapi configuration.
  3. amcd

    amcd New Member

    i already changed it from the default

    Memory Soft Limit - 120M
    Memory Soft Limit - 150M
  4. mistwang

    mistwang LiteSpeed Staff

    There is a bug which ignore the per application limits, will be fixed in next release. In the mean time, you can change the global limit under server->'security'->'CGI resource control'.
  5. amcd

    amcd New Member

    thank you, this has solved the problem.

    the default was 60M and 70M. i first changed it to 80M and 100M and it did not work. then i changed it to same as lsphp setting and it is now working at 120M and 150M

    but is that not too high? what would be an optimum level?

    is there any guide to tweaking/tuning lsws for best performance and optimum resource usage? i find that the help in the admin panel is helpful, but not very detailed, and leaves a less educated person like me craving for more

Share This Page