Need to run lshttpd with UID less than 60

Discussion in 'General' started by catfisch, Nov 6, 2008.

  1. catfisch

    catfisch New Member

    Hello all.
    I Need to run lshttpd with UID less than 50. It won't allow me to run it unless the UID and GID in /etc/passwd and /etc/groups is less then 50 and 10 respectivley. Is there a way to force it to start anyway? On the OS i'm using I would have to add 50 users; which I don't want to have to do. Oh.. and I can't run suexec either. I just need the binary to skip the checks for UID and GID altogether.
    Thanks!
    Cat
    Last edited: Nov 6, 2008
  2. mistwang

    mistwang LiteSpeed Staff

    The minimum UID required is 11, 60 should be fine.
  3. catfisch

    catfisch New Member

    I am trying to run it as UID 7 and the log/error.log says "user id must not be less then 50 and group id must not be less then 10. Please fix the above problem first!" So does this hold? Or is it in fact only 11?
    Thanks,
    V/R
    Cat
  4. mistwang

    mistwang LiteSpeed Staff

    It is 11, not 50.
  5. catfisch

    catfisch New Member

    OK i'll try to create (4) more users and just disable them. We'll see how that works.
    Thanks!
    -Cat
  6. catfisch

    catfisch New Member

    It does in fact start now (thank you!) ( ps-ef shows lscgid.3.3.22 and lshttpd.3.3.22) but I can't access it. I telneted to localhost 8888 and did a (get "/") but i don't get anything. Still looking into it. An Strace shows it looking for /proc/meminfo which could explain it. This OS doesn't use /proc or support threads allthough I don't see litespeed trying to do any threads. I'll keep trying ....
    Thanks!
    -Cat
  7. mistwang

    mistwang LiteSpeed Staff

    port is 8088 and 7080 by default.
  8. catfisch

    catfisch New Member

    but i changed them from the defaults. I get a response from nmap on 8888 and 7777 like I should but it can't serve a page. Any ideas?
    -Cat
  9. mistwang

    mistwang LiteSpeed Staff

    blocked by firewall?

Share This Page