permision error

Discussion in 'Install/Configuration' started by tasarla, Apr 23, 2009.

  1. tasarla

    tasarla New Member

    okey plese remove topic
    Last edited: Apr 24, 2009
  2. mistwang

    mistwang LiteSpeed Staff

    Sorry, I still could not understand your English and get an idea what is the problem.
    Maybe you should post some pictures.
  3. auser

    auser Super Moderator

    Hi tasarla,

    What I got from your post:
    1.you set directory
    /public_html/Themes/Night
    permission to 644

    2.then you start litespeed
    you found permission of
    /public_html/Themes/Night
    has changed to 744

    3.but when you start apache instead of litespeed,
    the directory's permission won't change -- remain as 644

    Please confirm if this is true, so that mistwang can further trouble-shooting the right problem. :)
  4. mistwang

    mistwang LiteSpeed Staff

    I think you should stop using PHP suEXEC, since PHP run as the user id of the owner of the directory, it can change the permission mask at will, when Apache is used, PHP is running as nobody, so PHP does not have permission to change the permission mask.
    The solution to your problem is to disable "PHP suEXEC".
  5. TomBG

    TomBG New Member

    PHP runs as the directory owner -- without PHP suEXEC (in LiteSpeed)?

Share This Page