Php 5.2.10

Discussion in 'Feedback/Feature Requests' started by piper, Jun 29, 2009.

  1. piper

    piper New Member

    Hi,

    Any plan to add PHP 5.2.10 to PHP compiler GUI? I know I can manually build it from cli, but having so many litespeed machine it makes it very time consuming :p

    Thanks for a great product
  2. mistwang

    mistwang LiteSpeed Staff

    You can download 4.0.5 package again, has been added.
  3. piper

    piper New Member

    thx, small problem, suhosin wasnt downloaded in gz

    gunzip: suhosin-patch-5.2.10.patch.gz: not in gzip format
  4. piper

    piper New Member

    More errors

    Fatal error: Error: cannot open phar "/opt/lsws/phpbuild/php-5.2.10/pear/install-pear-nozlib.phar" in /opt/lsws/phpbuild/php-5.2.10/pear/install-pear-nozlib.phar on line 795
    make[1]: *** [install-pear-installer] Error 255
    make: *** [install-pear] Error 2
    ls_install: Failed!
  5. mistwang

    mistwang LiteSpeed Staff

    Added 5.2.10 to the updated 4.0.5 package.
  6. piper

    piper New Member

    I still got this error

    mv /opt/lsws/fcgi-bin/lsphp-5.2.10 /opt/lsws/fcgi-bin/lsphp-5.2.10.bak; cp /opt/lsws/phpbuild/php-5.2.10/sapi/litespeed/php /opt/lsws/fcgi-bin/lsphp-5.2.10
    Installing PHP SAPI module: litespeed
    Installing PHP CLI binary: /opt/lsws/lsphp5/bin/
    Installing PHP CLI man page: /opt/lsws/lsphp5/man/man1/
    Installing build environment: /opt/lsws/lsphp5/lib/php/build/
    Installing header files: /opt/lsws/lsphp5/include/php/
    Installing helper programs: /opt/lsws/lsphp5/bin/
    program: phpize
    program: php-config
    Installing man pages: /opt/lsws/lsphp5/man/man1/
    page: phpize.1
    page: php-config.1
    Installing PEAR environment: /opt/lsws/lsphp5/lib/php/

    Fatal error: Error: cannot open phar "/opt/lsws/phpbuild/php-5.2.10/pear/install-pear-nozlib.phar" in /opt/lsws/phpbuild/php-5.2.10/pear/install-pear-nozlib.phar on line 795
    make[1]: *** [install-pear-installer] Error 255
    make: *** [install-pear] Error 2
    ls_install: Failed!
  7. piper

    piper New Member

    Looks like curlwrappers causes it, php 5.2.10 have problem compiling with curlwrapper and safe_mode
    Last edited: Jun 30, 2009
  8. bvierra

    bvierra New Member

    This is actually fixed in the latest snapshot from php... any ideas when we can get that put in?
  9. mistwang

    mistwang LiteSpeed Staff

    You can download the snap shot and rename it as 5.2.10 under phpbuild directory.
  10. DraCoola

    DraCoola Member

    I hope litespeed will officially support for php 5.2.11 soon.
    As I felt this version of php is better than 5.2.10.
  11. mistwang

    mistwang LiteSpeed Staff

    5.2.11 support has been added in our 4.0.11 release.
  12. DraCoola

    DraCoola Member

    Thank you George, I will try it now :)
  13. DraCoola

    DraCoola Member

    Did litespeed adding php 5.2.12 on lsws 4.0.12?
    Because php 5.2.12 has been added on Cpanel easy apache php list.
  14. mistwang

    mistwang LiteSpeed Staff

    Just upgrade PHP via cpeasyapache, then "Build Matching PHP" from LSWS plugin.
  15. DraCoola

    DraCoola Member

    I have did rebuild matching php version to 5.2.12
    But http://portal.dehostre.com showing error 503, while switch to apache finally fix that error 503.

    Should I back to php 5.2.11 for this moment?
  16. DraCoola

    DraCoola Member

    Switch to php 5.2.11 and that joomla site back to normal :)
  17. mistwang

    mistwang LiteSpeed Staff

    You have some mismatched PHP modules I think. those modules need to be build manually, it cannot be taken care of by cpeasyapache.

    try run
    /usr/local/lsws/fcgi-bin/lsphp-5.2.12 -i

    from command line, see if you got any error.

Share This Page