PHP 5.2.8 is out

Discussion in 'PHP' started by kuts, Dec 11, 2008.

  1. kuts

    kuts New Member

    You should include in the wiki how to edit the files of lsws when a new version of PHP is out so that we can upgrade PHP via PHP compile feature via LS panel.

    :confused:
    Last edited: Dec 11, 2008
  2. kuts

    kuts New Member

    LSWS 3.3.23 went out yesterday and didn't even include PHP 5.2.8, which was released 3 days ago.
  3. mistwang

    mistwang LiteSpeed Staff

    because suhosin patch for 5.2.8 was not available yesterday.
  4. kuts

    kuts New Member

    touche

    oh well
  5. mistwang

    mistwang LiteSpeed Staff

    The latest build of release 3.3.23 has 5.2.8 now. but it wont work unless the suhosin patch become available.
  6. piper

    piper New Member

    anyway to install 5.2.8 with suhosin for php 5.2.7?

    i saw cpanel allows it
  7. yulia

    yulia New Member

    I wouldn't be to hasty to upgrade to it just yet... theres been a few compatibility issues with a few applications.
  8. piper

    piper New Member

    suhosin patch for 5.2.8 is out

    anyway to update them?
  9. kuts

    kuts New Member

    yep how to update please :)

    or release a LSWS 3.3.23 with updated versions for PHP compile
    Last edited: Dec 17, 2008
  10. mistwang

    mistwang LiteSpeed Staff

    Just download 3.3.23 package and upgrade again, it should work.
  11. kuts

    kuts New Member

    just upgraded my PHP to 5.2.8 with suhosin, mail header patch, and eaccelerator

    thanks
  12. kas

    kas New Member

    I'm still unable to build php with the suhosin patch... :confused:

    I have noticed that signatures for both suhosin-patch-5.2.8 and suhosin-patch-5.2.7 are identical.

    The patch 'suhosin-patch-5.2.8' contains the following string:

    'diff -Nura php-5.2.7/TSRM/tsrm_virtual_cwd.c suhosin-patch-5.2.7-0.9.6.3/TSRM/tsrm_virtual_cwd.c'

    And that's why patch cannot be applied.

    Any ideas?
  13. mistwang

    mistwang LiteSpeed Staff

    download lsws-3.3.23 package again, it has been addressed.
  14. kas

    kas New Member

    We have already installed lsws-3.3.23 and it is already running.

    How can I upgrade it again?
  15. mistwang

    mistwang LiteSpeed Staff

    run the installer from command line.
  16. kuts

    kuts New Member

    Run ./install.sh

    and

    choose Upgrade even though it's still the same version

Share This Page