php.ini location not being set

Discussion in 'Bug Reports' started by Frankk912, Aug 19, 2013.

  1. Frankk912

    Frankk912 New Member

    Hello,

    After I upgraded LSWS to 4.2.4 and PHP LSAPI to 6.3, my command-line options for specifying the php.ini location aren't working.

    This is the external app command I've always been using:
    Code:
    $SERVER_ROOT/fcgi-bin/lsphp5 -c /home/user/conf/php.ini
    phpinfo() is showing that no configuration file is loaded even though php.ini exists with the correct permissions. Again, this was working fine till I upgraded.

    CentOS 6.4 x64, PHP 5.5.2

    Any ideas?

    Thanks
    Last edited: Aug 19, 2013
  2. Frankk912

    Frankk912 New Member

    I added the PHPRC environment variable and it now works. Will -c not work again?
  3. NiteWave

    NiteWave Administrator

    it looks lsapi 6.3 disable -c option. however if run command line, "-c option" still effective. can you confirm ?
  4. Frankk912

    Frankk912 New Member

    Yep, that's what it looks like.
  5. mistwang

    mistwang LiteSpeed Staff

    Our internal test shows that -c option works. you can try from command line:

    Maybe you selected PHP suEXEC daemon mode? which is not compatible with per user php.ini.
  6. mistwang

    mistwang LiteSpeed Staff

    Please rebuild PHP with updated lsapi 6.3 code.
    If you use cPanel to build matching PHP, do

    rm -f /home/cpeasyapache/ls.src/php-litespeed-6.3.tgz

    if you use web console, do

    rm -f /usr/local/lsws/phpbuild/php-litespeed-6.3.tgz

Share This Page