PHP suEXEC daemon mode doesn't read in PHP_INI_SCAN_DIR php.ini

Discussion in 'Install/Configuration' started by craigles, Oct 5, 2012.

  1. craigles

    craigles New Member

    Hi Guys,

    Just deployed 4.2 onto a server to see if it would fix a previous problem, and also did the whole recompile of php and turned on the PHP suEXEC Daemon mode to give it a good test.

    It works fantastic, except for the small fact that it will not read in per user php.ini despite the setting being in the Environment section:

    PHP_INI_SCAN_DIR=$VH_ROOT/public_html

    Switching straight back from the PHP suEXEC Daemon mode fixes the issue straight away and it starts reading in the per user php.ini's again.

    Is this just a bug, or will this be the case and if you use PHP_INI_SCAN_DIR you won't be able to use PHP suEXEC Daemon?

    Cheers,
    Craig
  2. NiteWave

    NiteWave Administrator

    are you using cagefs at the same time?
  3. craigles

    craigles New Member

    No... We are just using normal LVE.
    Not CageFS.
    Not yet anyway.
  4. NiteWave

    NiteWave Administrator

    it may still relate to lve.

    see if you can disable lve for a while and see if PHP_INI_SCAN_DIR works
  5. craigles

    craigles New Member

    I turned off LVE in LiteSpeed to see what would happen, but it still doesn't pick up the php.ini at all.
  6. Jesse

    Jesse New Member

    Is there any quick workaround to this issue so we can operate on 4.2, will we have to wait til 4.2.1 or is the new behaviour deemed correct?
  7. NiteWave

    NiteWave Administrator

  8. Jesse

    Jesse New Member

Share This Page