PHP Versions

Discussion in 'General' started by DanEZPZ, Nov 2, 2009.

  1. DanEZPZ

    DanEZPZ New Member

    Which PHP version is it safe to run with Litespeed? I've heard of random errors with PHP 5.3 and I seem to recall something about 5.2.1?

    Have any of these problems been fixed?
  2. Tony

    Tony Member

    We've had no issues running PHP 5.2.11. 5.2.10 apparently had some issues though but even when running it as a cgi or mod_php that version had crashing problems.
  3. DanEZPZ

    DanEZPZ New Member

    Thanks Tony, just upgraded to 5.2.11 and seems to be working fine.
  4. Tony

    Tony Member

    Well I forgot one thing to mention as a warning. Some scripts encoded with very old versions of Zend Guard / Zend Encoder will crash. This typically should not be an issue it seems to be problems with files encoded several years ago and Zend Optimizer causes a PHP crash when it parses them.

Share This Page