PHP6: Working, but no SuExec

Discussion in 'Feedback/Feature Requests' started by Gerry, Jun 19, 2008.

  1. Gerry

    Gerry Member

    I managed to get PHP6-dev more or less working with the Litespeed LSAPI.

    I had to comment out all references to php_end_ob_buffers() in lsapi_main.c, because that is apparently not supported in PHP6, but aside from this it compiled cleanly.

    Would there be any chance for the Litespeed dev's to investigate why PHP6 does not work with SuExec? I know PHP6 is still in development, but we would like to offer this to a limited set of customers that are developing beeding edge applications and would like to use the upcoming major PHP version.
  2. mistwang

    mistwang LiteSpeed Staff

    LSWS does not enabled suEXEC for "application/x-httpd-php6" yet. Will be added in our 4.0 release. however, you can create a script handle for "pthml" suffix using the PHP6 external app. And use "AddType application/x-httpd-phtml .php" to have PHP6 handle php scripts.
  3. Gerry

    Gerry Member

    I have a new question concerning this problem. Currently we offer PHP4 (4.4.9), PHP5 (5.2.8) and PHP6 (dev).
    I would like to add one more PHP version, PHP5.3, and offer it separately. Is there a way to do this cleanly? The 'phtml' was kind of hack-ish.

    If you rely on the "AddType application/x-httpd-XXX .php" to determine if SuEXEC is available, might I suggest checking for "AddType application/x-httpd-php(.*) .php"? That way I could do something like "AddType application/x-httpd-php53 .php", which would be a lot cleaner.
  4. mistwang

    mistwang LiteSpeed Staff

    We will check what we can do about it.
  5. mistwang

    mistwang LiteSpeed Staff

    PHP suEXEC for application/x-httpd-php6 has been added a while ago.
  6. heavy

    heavy New Member

    Yes this is limiting us to give more php versions.

    Maybe option in handlers to enable disable suexec?

Share This Page