problem in rebuild

Discussion in 'Install/Configuration' started by 3245, Aug 29, 2013.

  1. 3245

    3245 Member

    hello
    when i run "Build Matching PHP Binary"
    after some time, i see following error in last line's:

    PHP:
    /bin/sh /home/cpeasyapache/ls.src/php-5.4.19/libtool --silent --preserve-dup-deps --mode=link cc -export-dynamic -I/usr/include --O2 -fvisibility=hidden  -L/opt/xml2/lib -L/opt/pcre/lib64 -L/opt/curlssl/lib -L/opt/curlssl//lib64 -L/opt/php_with_imap_client//lib64  -R /opt/xml2/lib -R /opt/pcre/lib64 -R /opt/curlssl/lib -R /opt/curlssl//lib64 -R /opt/php_with_imap_client//lib64 ext/date/php_date.lo ext/date/lib/astro.lo ext/date/lib/dow.lo ext/date/lib/parse_date.lo ext/date/lib/parse_tz.lo ext/date/lib/timelib.lo ext/date/lib/tm2unixtime.lo ext/date/lib/unixtime2tm.lo ext/date/lib/parse_iso_intervals.lo ext/date/lib/interval.lo ext/ereg/ereg.lo ext/ereg/regex/regcomp.lo ext/ereg/regex/regexec.lo ext/ereg/regex/regerror.lo ext/ereg/regex/regfree.lo ext/libxml/libxml.lo ext/openssl/openssl.lo ext/openssl/xp_ssl.lo ext/pcre/php_pcre.lo ext/sqlite3/sqlite3.lo ext/sqlite3/libsqlite/sqlite3.lo ext/zlib/zlib.lo ext/zlib/zlib_fopen_wrapper.lo ext/zlib/zlib_filter.lo ext/bcmath/bcmath.lo ext/bcmath/libbcmath/src/add.lo ext/bcmath/libbcmath/src/div.lo ext/bcmath/libbcmath/src/init.lo ext/bcmath/libbcmath/src/neg.lo ext/bcmath/libbcmath/src/outofmem.lo ext/bcmath/libbcmath/src/raisemod.lo ext/bcmath/libbcmath/src/rt.lo ext/bcmath/libbcmath/src/sub.lo ext/bcmath/libbcmath/src/compare.lo ext/bcmath/libbcmath/src/divmod.lo ext/bcmath/libbcmath/src/int2num.lo ext/bcmath/libbcmath/src/num2long.lo ext/bcmath/libbcmath/src/output.lo ext/bcmath/libbcmath/src/recmul.lo ext/bcmath/libbcmath/src/sqrt.lo ext/bcmath/libbcmath/src/zero.lo ext/bcmath/libbcmath/src/debug.lo ext/bcmath/libbcmath/src/doaddsub.lo ext/bcmath/libbcmath/src/nearzero.lo ext/bcmath/libbcmath/src/num2str.lo ext/bcmath/libbcmath/src/raise.lo ext/bcmath/libbcmath/src/rmzero.lo ext/bcmath/libbcmath/src/str2num.lo ext/calendar/calendar.lo ext/calendar/dow.lo ext/calendar/french.lo ext/calendar/gregor.lo ext/calendar/jewish.lo ext/calendar/julian.lo ext/calendar/easter.lo ext/calendar/cal_unix.lo ext/ctype/ctype.lo ext/curl/interface.lo ext/curl/multi.lo ext/curl/streams.lo ext/dom/php_dom.lo ext/dom/attr.lo ext/dom/document.lo ext/dom/domerrorhandler.lo ext/dom/domstringlist.lo ext/dom/domexception.lo ext/dom/namelist.lo ext/dom/processinginstruction.lo ext/dom/cdatasection.lo ext/dom/documentfragment.lo ext/dom/domimplementation.lo ext/dom/element.lo ext/dom/node.lo ext/dom/string_extend.lo ext/dom/characterdata.lo ext/dom/documenttype.lo ext/dom/domimplementationlist.lo ext/dom/entity.lo ext/dom/nodelist.lo ext/dom/text.lo ext/dom/comment.lo ext/dom/domconfiguration.lo ext/dom/domimplementationsource.lo ext/dom/entityreference.lo ext/dom/notation.lo ext/dom/xpath.lo ext/dom/dom_iterators.lo ext/dom/typeinfo.lo ext/dom/domerror.lo ext/dom/domlocator.lo ext/dom/namednodemap.lo ext/dom/userdatahandler.lo ext/filter/filter.lo ext/filter/sanitizing_filters.lo ext/filter/logical_filters.lo ext/filter/callback_filter.lo ext/ftp/php_ftp.lo ext/ftp/ftp.lo ext/hash/hash.lo ext/hash/hash_md.lo ext/hash/hash_sha.lo ext/hash/hash_ripemd.lo ext/hash/hash_haval.lo ext/hash/hash_tiger.lo ext/hash/hash_gost.lo ext/hash/hash_snefru.lo ext/hash/hash_whirlpool.lo ext/hash/hash_adler32.lo ext/hash/hash_crc32.lo ext/hash/hash_fnv.lo ext/hash/hash_joaat.lo ext/iconv/iconv.lo ext/imap/php_imap.lo ext/json/json.lo ext/json/utf8_decode.lo ext/json/JSON_parser.lo ext/mysql/php_mysql.lo ext/phar/util.lo ext/phar/tar.lo ext/phar/zip.lo ext/phar/stream.lo ext/phar/func_interceptors.lo ext/phar/dirstream.lo ext/phar/phar.lo ext/phar/phar_object.lo ext/phar/phar_path_check.lo ext/posix/posix.lo ext/reflection/php_reflection.lo ext/session/mod_user_class.lo ext/session/session.lo ext/session/mod_files.lo ext/session/mod_mm.lo ext/session/mod_user.lo ext/simplexml/simplexml.lo ext/simplexml/sxe.lo ext/sockets/sockets.lo ext/sockets/multicast.lo ext/spl/php_spl.lo ext/spl/spl_functions.lo ext/spl/spl_engine.lo ext/spl/spl_iterators.lo ext/spl/spl_array.lo ext/spl/spl_directory.lo ext/spl/spl_exceptions.lo ext/spl/spl_observer.lo ext/spl/spl_dllist.lo ext/spl/spl_heap.lo ext/spl/spl_fixedarray.lo ext/standard/crypt_freesec.lo ext/standard/crypt_blowfish.lo ext/standard/crypt_sha512.lo ext/standard/crypt_sha256.lo ext/standard/php_crypt_r.lo ext/standard/array.lo ext/standard/base64.lo ext/standard/basic_functions.lo ext/standard/browscap.lo ext/standard/crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo ext/standard/datetime.lo ext/standard/dir.lo ext/standard/dl.lo ext/standard/dns.lo ext/standard/exec.lo ext/standard/file.lo ext/standard/filestat.lo ext/standard/flock_compat.lo ext/standard/formatted_print.lo ext/standard/fsock.lo ext/standard/head.lo ext/standard/html.lo ext/standard/image.lo ext/standard/info.lo ext/standard/iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/standard/mail.lo ext/standard/math.lo ext/standard/md5.lo ext/standard/metaphone.lo ext/standard/microtime.lo ext/standard/pack.lo ext/standard/pageinfo.lo ext/standard/quot_print.lo ext/standard/rand.lo ext/standard/soundex.lo ext/standard/string.lo ext/standard/scanf.lo ext/standard/syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/standard/url.lo ext/standard/var.lo ext/standard/versioning.lo ext/standard/assert.lo ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/standard/incomplete_class.lo ext/standard/url_scanner_ex.lo ext/standard/ftp_fopen_wrapper.lo ext/standard/http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo ext/standard/credits.lo ext/standard/css.lo ext/standard/var_unserializer.lo ext/standard/ftok.lo ext/standard/sha1.lo ext/standard/user_filters.lo ext/standard/uuencode.lo ext/standard/filters.lo ext/standard/proc_open.lo ext/standard/streamsfuncs.lo ext/standard/http.lo ext/tokenizer/tokenizer.lo ext/tokenizer/tokenizer_data.lo ext/xml/xml.lo ext/xml/compat.lo ext/xmlreader/php_xmlreader.lo ext/xmlwriter/php_xmlwriter.lo TSRM/TSRM.lo TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/fopen_wrappers.lo main/alloca.lo main/php_scandir.lo main/php_ini.lo main/SAPI.lo main/rfc1867.lo main/php_content_types.lo main/strlcpy.lo main/strlcat.lo main/mergesort.lo main/reentrancy.lo main/php_variables.lo main/php_ticks.lo main/network.lo main/php_open_temporary_file.lo main/php_logos.lo main/output.lo main/getopt.lo main/streams/streams.lo main/streams/cast.lo main/streams/memory.lo main/streams/filter.lo main/streams/plain_wrapper.lo main/streams/userspace.lo main/streams/transports.lo main/streams/xp_socket.lo main/streams/mmap.lo main/streams/glob_wrapper.lo Zend/zend_language_parser.lo Zend/zend_language_scanner.lo Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend/zend_dtrace.lo Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_gc.lo Zend/zend_closures.lo Zend/zend_float.lo Zend/zend_string.lo Zend/zend_signal.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo main/internal_functions_cli.lo sapi/cli/php_cli.lo sapi/cli/php_http_parser.lo sapi/cli/php_cli_server.lo -lcrypt -lc-client -lcrypt -lmysqlclient -lcrypto -lssl -lcrypto -lcrypt -lpam -lcrypto -lssl -lcrypto -lcurl -lz -lpcre -lcrypto -lssl -lcrypto -lrt -lm -ldl -lnsl -lxml2 -lz -lm -ldl -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lcurl -lidn -lssl -lcrypto -lrt -lz -lxml2 -lz -lm -ldl -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lxml2 -lz -lm -ldl -lcrypt -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lcrypt  -o sapi/cli/php
    /opt/php_with_imap_client//lib64/libc-client.a(osdep.o): In function `ssl_onceonlyinit':
    /home/cpeasyapache/src/imap-2007f/c-client/osdep.c:302warningthe use of `tmpnam' is dangerous, better use `mkstemp'
    make: *** No rule to make target `litespeed'
    needed by `all'.  Stop.
    **ERROR** Could not compile PHP
    i run
    PHP:
    root@host [~]# yum install libxml2-devel
    out:
    PHP:
    Loaded pluginsfastestmirrorsecurity
    Loading mirror speeds from cached hostfile
     
    basecentos.mirror.constant.com
     
    extrascentos.someimage.com
     
    updatescentos.vipernetworksystems.com
    Setting up Install Process
    Package libxml2
    -devel-2.7.6-12.el6_4.1.x86_64 already installed and latest version
    i run:
    PHP:
    root@host [~]# yum install patch.x86_64 gcc.x86_64 glibc.x86_64 libstdc++.x86_64 gcc-c++.x86_64 \binutils.x86_64 libtool.x86_64 autoconf.x86_64 make.x86_64
    out:
    PHP:
    Loaded pluginsfastestmirrorsecurity
    Package patch
    -2.6-6.el6.x86_64 already installed and latest version
    Package gcc
    -4.4.7-3.el6.x86_64 already installed and latest version
    Package glibc
    -2.12-1.107.el6_4.4.x86_64 already installed and latest version
    Package libstdc
    ++-4.4.7-3.el6.x86_64 already installed and latest version
    Package gcc
    -c++-4.4.7-3.el6.x86_64 already installed and latest version
    Package binutils
    -2.20.51.0.2-5.36.el6.x86_64 already installed and latest version
    Package libtool
    -2.2.6-15.5.el6.x86_64 already installed and latest version
    No package autoconf
    .x86_64 available.
    Package 1:make-3.81-20.el6.x86_64 already installed and latest version
    Nothing to 
    do
    Please help me.

    Thanks.
  2. NiteWave

    NiteWave Administrator

  3. 3245

    3245 Member

    i do force-reinstall, but also i still have problem
  4. NiteWave

    NiteWave Administrator

    before "Build Matching PHP", have you succeeded to run easyApache to build php-5.4.19 ?
  5. 3245

    3245 Member

    Yes, i have succeded run easyApache to build php-5.4.19 without problem.
  6. NiteWave

    NiteWave Administrator

    can you PM the root so that we can have further checks.
  7. 3245

    3245 Member

    Forgive me,
    this server is for Government Site's,
    Requires authorization for access to you,
    if possible, can you give command or anything for resolve them?

    problem is for following:
    have you any idea?
    Last edited: Aug 31, 2013
  8. 3245

    3245 Member

    question2: /usr/local/lsws/fcgi-bin/lsphp5 symlinked to /usr/local/bin/php ??? it is correct?
  9. 3245

    3245 Member

    they are is correct:
    lsphp4 is symlinked to -> ./lsphp*
    and
    lsphp5 is symlinked to -> ./lsphp*

    they are correct?
  10. NiteWave

    NiteWave Administrator

    what is ./lsphp ?

    #./lsphp -v

    does Build Matching PHP only fail with php-5.4.19 ?
    have any success to build matching php with other php version?
  11. 3245

    3245 Member

    i run ./lsphp -v
    out:
    i run php from source, now i see just following error:
  12. 3245

    3245 Member

    Good, i found problem,
    when i did downgrade to 5.3.27 i have not any problem, it is complete succesfully,
    but when i want upgrade to 5.4.19, i have same problem, have you any idea?

    Thanks.
  13. 3245

    3245 Member

    Thanks for all,
    that is resolved after upgrade to latest version.
  14. 3245

    3245 Member

    just i see following error in lsws consol:
    [​IMG]
    That is important?
    i make restart lsws in ssh, and also i restart server, but still see this error,
    but site's is running correctly without problem.

    -how i can sure litespeed installed currently and configured?

    [​IMG]

    i have just a site for test,
    if above error's warning have not problem, let me know.
    Last edited: Sep 1, 2013
  15. NiteWave

    NiteWave Administrator

    how about do a full stop/start, see if this error still show up.
  16. 3245

    3245 Member

    i runed
    service lsws restart
    but again see same error's
    this error's have problem in future?
    becuase i have not any problem in load site.
    Last edited: Sep 2, 2013
  17. NiteWave

    NiteWave Administrator

    service lsws restart
    is graceful restart, not full stop/start.

    full stop/start:
    #cd /usr/local/lsws/bin
    #./lswsctrl stop
    ensure no litespeed process is running,then
    #./lswsctl start
  18. 3245

    3245 Member

    still i see same error warnin:
    [​IMG]

    Have you any Idea?

    Thanks.
  19. mistwang

    mistwang LiteSpeed Staff

    You can ignore that message as LSWS use Apache configuration file. that's normal.

Share This Page