Problem installing PHP/LSAPI

Discussion in 'PHP' started by Dondi, Apr 5, 2007.

  1. Dondi

    Dondi New Member

    I encountered the following error while executing PHP/LSAPI installation step 4 from the Wiki:

    The prior 3 steps all completed without error.

    FYI: I am setting up a slicehost 256 VPS (w/ ubuntu) and have already installed litespeed successfully. I am a LINUX newbie, so I am unclear about steps to remedy this.

    Any suggestions are appreciated.

    Dondi.
  2. layer

    layer New Member

    Dondi,

    I ran into this, but fixed it via:

    Code:
    http://ftp.gnu.org/gnu/autoconf/autoconf-2.13.tar.gz
    tar zfx autoconf-2.13.tar.gz
    cd autoconf-2.13
    ./configure
    make
    make install
    
    Then run the buildconf again. :)
  3. Dondi

    Dondi New Member

    Thanks layer.

    I tried your suggestion (using the latest autoconf) and got the following error:

    Looks like I'm heading down a rabbit hole! Any suggestions?

    Dondi.
  4. layer

    layer New Member

    Please use the autoconf that was in my post, it is the one that will fix the issue.
  5. Dondi

    Dondi New Member

    Thanks again layer. However, I used the autoconf-2.13 and got essentially the same error. Here are the execution results:

    Thoughts?
  6. layer

    layer New Member

    Code:
    wget ftp://ftp.gnu.org/gnu/m4/m4-1.4.9.tar.gz
    tar zfx m4-1.4.9.tar.gz
    cd m4-1.4.9
    ./configure
    make
    make install
    
    then go back to autoconf, then go back to buildconf ;)
  7. Dondi

    Dondi New Member

    Thanks layer! I had to install libxml2 in the same way as well, plus use sudo install, but your suggestion worked like a charm.

    Now I've run into a problem with step 6:

    I get this error:

    I have looked all over and can find neither the 'lwsinstall/fcgi-bin' directories nor the 'lsphp' file. This is maddening. Please help!

    Thanks,

    Dondi.
  8. layer

    layer New Member

    That isn't an error, it just means that you need to replace lswsinstall with where you installed lsws ;)

    default is /opt/lsws.
  9. Dondi

    Dondi New Member

    layer,

    Thank you so much for your assistance and your patience in putting up with the many Duh! moments. I was able to get through the full setup with your help. It is very much appreciated.

    Dondi.
  10. layer

    layer New Member

    No problem, glad to hear you got this working. :)

    Hope your experience with Litespeed is as good as mine has been so far.
  11. Dondi

    Dondi New Member

    You are a generous soul layer. I hope I have the same positive experience as you as well. I am new to Linux, VPS, etc., but decided to give LiteSpeed a shot as I have heard that it runs more efficiently than Apache on my tight 256MB slice (VPS). My next steps are to get MediaWiki running, then a Rails app that I've been hacking out on my Mac. Thanks again for all of your help.

    Dondi.
  12. yogabasics

    yogabasics New Member

    autoconf not found.

    I'm getting the same error when I try to compile PHP "buildconf: autoconf not found.
    You need autoconf version 2.13 or newer installed
    to build PHP from CVS.
    make: *** [buildmk.stamp] Error 1"

    I'm on Dreamhost and using the following to install autoconf:
    Code:
    wget ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/distfiles/autoconf-2.61.tar.gz
    wget ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/distfiles/automake-1.10.1.tar.bz2
    tar xzf autoconf-2.61.tar.gz
    tar xjf automake-1.10.1.tar.bz2
    cd autoconf-2.61
    ./configure

Share This Page