Problem with AWStats

Discussion in 'Install/Configuration' started by Tadeo, Feb 21, 2005.

  1. Tadeo

    Tadeo New Member

    Hello,

    I seem to be having a problem accessing an awstats page on one of my virtual hosts. Any attempt to access the page returns a 403 (Forbidden). I have another virtual host with the same awstats settings (except for hostname) that is working perfectly fine. Any suggestions on what I should look for?


    Thanks,

    Thad
  2. mistwang

    mistwang LiteSpeed Staff

    Is awstats in dynamic mode? If so, you need to set "Enable Script" to "Yes" for that virtual host at the page that you can add a virtual host.
  3. Tadeo

    Tadeo New Member

    It is in dynamic mode. And enable script is set to yes. (I verified the setting in the configuration file). Any other suggestions that I might try?


    Thanks
  4. mistwang

    mistwang LiteSpeed Staff

    Make sure you looked at the right configuration file, it is in httpd_config.xml, not the virtual host coniguration file.
    If that is not the problem, you have to compare the configuration of two virtual host carefully.
    Please check "setUIDMode", and make sure the corresponding file/directory is not owned by "root" or other system user. LSWS won't start a CGI script as a privilege user.

    If possible, enable debug logging for that virtual host and set "debug level" to "high" at server level.
  5. Tadeo

    Tadeo New Member

    The following error is returned in the error log:
    2005-02-21 13:01:46.226 [INFO] [] Access denied, UID or GID is smaller than minimum UID, GID configured.

    setUIDMode is 0 (False)
  6. mistwang

    mistwang LiteSpeed Staff

    Awstats CGI always run in setuid mode, as the owner of the document root. Change the owner of the document root to a normal user, it will work properly. :)
  7. Da-Idiot

    Da-Idiot New Member

    This is a new problem, but irelates to a problem with awstats. Since this post is from today i figured i would post here.

    I cannot get the awstats to update with pages in my awstats directory.

    I have it set to static so it will generate static pages. When i try to go to the awstats page i get the 404 not found error.

    I have checked in the awstats directory that i set for the virtual host but it is not creating any files.

    I have run the awstats install script that comes with lsws. What am i missing here.

    Please let me know whatever other info you need.

    Thanx
  8. Tadeo

    Tadeo New Member

    I think I solved the problem. It appears that it was the group that the doc root was assigned to that kept it from working. I first changed the owner of the doc root with no success; then I changed the group it belong to ans it started to work again. :)

    Thanks for your assistance. :)
  9. mistwang

    mistwang LiteSpeed Staff

    Check your lsws/logs/stderr.log, I think the log format is not configured properly, with the default awstats log format, you have to enable "UserAgent" and "Referrer" logging in lsws's access log configuration, otherwise you need to customize awstats' log format configuration.
    Also, make sure the permission of awstats working directory is set properly.

Share This Page