Problem with lsws- server hangups

Discussion in 'General' started by linuxpl.com, Sep 28, 2007.

  1. linuxpl.com

    linuxpl.com New Member

    Hello
    I have a seriously problem with lsws. I host only one site on it . i have also bought a lsws license. While having high traffic lsws tends to not serve new requests , it hangups , only restart helps.

    my logs

    Every 1s: cat /tmp/lshttpd/.rtreport Fri Sep 28 12:24:50 2007
    VERSION: LiteSpeed Web Server/Enterprise/3.2.3
    UPTIME: 00:00:23
    BPS_IN: 73, BPS_OUT: 624, SSL_BPS_IN: 0, SSL_BPS_OUT: 0
    MAXCONN: 2000, MAXSSL_CONN: 200, PLAINCONN: 365, AVAILCONN: 1635, IDLECONN: 351, SSLCONN: 0, AVAILSSL: 200
    REQ_RATE []: REQ_PROCESSING: 14, REQ_PER_SEC: 155, TOT_REQS: 5689
    REQ_RATE [tapety.poszkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [gryonline.poszkole.pl]: REQ_PROCESSING: 1, REQ_PER_SEC: 17, TOT_REQS: 551
    REQ_RATE [programy.poszkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [gry.poszkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [video.poszkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [wildposzkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 3
    REQ_RATE [tapsy.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 1
    REQ_RATE [_AdminVHost]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 2
    REQ_RATE [magiel.net]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [Example]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [filmiki.poszkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [poszkole.pl]: REQ_PROCESSING: 13, REQ_PER_SEC: 138, TOT_REQS: 5132
    REQ_RATE [filmy.poszkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [pytam]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [teledyski.poszkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    REQ_RATE [humor.poszkole.pl]: REQ_PROCESSING: 0, REQ_PER_SEC: 0, TOT_REQS: 0
    EXTAPP [LSAPI] [] [phpLsapi]: CMAXCONN: 50, EMAXCONN: 50, POOL_SIZE: 20, INUSE_CONN: 1, IDLE_CONN: 19, WAITQUE_DEPTH: 0, REQ_
    PER_SEC: 38, TOT_REQS: 1156
    EOF

    or EVEN MAXCONN: 2000, MAXSSL_CONN: 200, PLAINCONN: 1180, AVAILCONN: 820

    are there any special settings on pages having many amount of served requests?
    any suggestions how to optimalize it


    Regards
    Greg
  2. mistwang

    mistwang LiteSpeed Staff

    Please check WAITQUE_DEPTH of phpLsapi during a taffic surge, if it is very high, you need to improve you PHP/MySQL code, as it is not able to keep up with the traffic. You can try raising "Max connection" of phpLsapi, but it may not help much.

    You can also looking into our Anti-DoS configuration: http://www.litespeedtech.com/how-tos.html#qa_dos

Share This Page