Quick Edit and iowait

Discussion in 'General' started by anewday, Apr 19, 2008.

  1. anewday

    anewday Moderator

    Ok, I don't stream any media files on the server. Max I/O is set to 150M, it should be enough for a forum withi media downloads? The ethernet port is 100Mbit. :)
  2. mistwang

    mistwang LiteSpeed Staff

    I/O Buffer is only for PHP request/response, won't affect media files, unless the media files were sent through PHP. Does it work better with larger I/O buffer today?
  3. anewday

    anewday Moderator

    Can't notice any difference I have tried 150M and 200M. Another observation is that posting messages for the first time doesn't cause any high iowait isues. It's just subsequent edits that do. Very strange...
    Last edited: Apr 24, 2008
  4. mistwang

    mistwang LiteSpeed Staff

  5. anewday

    anewday Moderator

    Ok, I will try it later. :) But some posts I edit contain less than 10 letters.
  6. furimedia

    furimedia New Member

    I think I also have this problem.
    My server was always usually less than 1 but now it just averages 1 and higher.

    What does setting to /dev/shm do? I am guessing it will uses System RAM instead of accessing disk and if this is the case, shouldn't using /dev/shm be the default behaviour for maximum performance?
  7. anewday

    anewday Moderator

    That's what I want to know too. Also, if Memory I/O Buffer is not full (as in my case) then how would setting the path to /dev/shm help since it doesn't have a need for it. :confused: Please clarify.
    Last edited: Apr 24, 2008
  8. mistwang

    mistwang LiteSpeed Staff

    We use on disk buffer mainly for buffering the large request body for those site dealing with large media files, let a 600MB media file fill up the memory is not a good idea, and there could be 20 upload sessions at the same time.

    Let's see what we can do about it. At least we can set the threshold higher when there are enough free memory.
  9. anewday

    anewday Moderator

    George, so setting the swapping directory to /dev/shm is useless since my Memory I/O Buffer is not full, right? I don't stream any media files by php, either.
  10. mistwang

    mistwang LiteSpeed Staff

    No, it should help. as current LSWS release use 1MB as the threshold on whether to use the on disk buffer.
    When a request has a request body larger than the threshold, the on disk buffer will be used no matter the memory I/O buffer is full or not.

    We will change it to 10MB in 3.3.11 release.
  11. anewday

    anewday Moderator

    Ok, sounds good. Should include the threshold value on the tooltip in web console. Maybe even allow user to define it. :) Thanks!
  12. miracle

    miracle New Member

    10MB is more than enough in most cases? Why not make LSWS uses as much memory as possible, instead of use disk buffer?
  13. anewday

    anewday Moderator

    Quick/regular edit and moving topics still causes high iowait occassionally in 3.3.11 Do you think it's good to disable mysql persistent connections in php.ini ?
    Last edited: Apr 26, 2008
  14. anewday

    anewday Moderator

    Code:
    2008-04-26 10:52:22.678	INFO	[AdminPHP] pid list size: 1
    2008-04-26 10:52:22.678	INFO	[AdminPHP] add child process pid: 7016
    This shows up in the error_log file whenever the load spikes due to iowait. hmmmm.

    How to lessen those on the error_log file?
    Last edited: Apr 26, 2008
  15. mistwang

    mistwang LiteSpeed Staff

    That's just because you are using the Admin console.
  16. mistwang

    mistwang LiteSpeed Staff

    does not matter.
  17. anewday

    anewday Moderator

    I wasn't using the Admin Console during the timestamps though.

Share This Page