Rails Timeout Error / LS Buffer Empty Error

Discussion in 'Ruby/Rails' started by malffred, Jul 3, 2007.

  1. malffred

    malffred New Member

    I've ran across the following errors at random in my rails app:

    Code:
    A Timeout::Error occurred in users#create:
    
     execution expired
     /usr/lib/ruby/1.8/timeout.rb:54:in `rbuf_fill'
    
    -------------------------------
    Backtrace:
    -------------------------------
    
     /usr/lib/ruby/1.8/timeout.rb:54:in `rbuf_fill'
     /usr/lib/ruby/1.8/timeout.rb:56:in `timeout'
     /usr/lib/ruby/1.8/timeout.rb:76:in `timeout'
    
    If I look in the LS error logs I see this:


    Code:
    2007-07-03 14:20:53.956 [NOTICE] Server Restart Request via Signal...
    2007-07-03 14:20:53.956 [NOTICE] [Child: 28061] Start shutting down gracefully ...
    2007-07-03 14:20:53.956 [INFO] Stop listener *:80.
    2007-07-03 14:20:53.956 [INFO] Stop listener *:443.
    2007-07-03 14:20:53.956 [INFO] Stop listener *:81.
    2007-07-03 14:20:54.306 [INFO] [81.151.63.193:51687-0#manage.sugarstats.com] Connection idle time: 31 while in state: 5 watching for event: 25,close!
    2007-07-03 14:20:54.306 [INFO] [81.151.63.193:51687-0#manage.sugarstats.com] Content len: 1625, Request line: 
    POST /users HTTP/1.1
    2007-07-03 14:20:54.306 [INFO] [81.151.63.193:51687-0#manage.sugarstats.com] Redirect: #1, URL: /dispatch.lsapi
    2007-07-03 14:20:54.306 [INFO] [81.151.63.193:51687-0#manage.sugarstats.com] HttpExtConnector state: 8, request body sent: 1625, response body size: 0, response body sent:0, left in buffer: 0, attempts: 0.
    2007-07-03 14:20:54.544 [NOTICE] [Child: 28061] Shut down successfully! 
    2007-07-03 14:20:54.544 [NOTICE] [AdminPHP] stop worker processes
    2007-07-03 14:20:54.544 [NOTICE] [Rails:manage.sugarstats.com:/] stop worker processes
    2007-07-03 14:20:54.589 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets belong to process 28061 !
    2007-07-03 14:20:54.696 [NOTICE] [AutoRestarter] child process with pid=28061 exited with status=0!
    2007-07-03 14:20:54.696 [NOTICE] [PID:28059] Server Stopped!
    Notice the "left in buffer: 0". I am sure no one restarted/stopped the server either.

    What does this mean? If I do "free -m" there is plenty of memory on the server (a 512MB VPS), should I up the Rails app buffer/timeout settings in LS? Or does this have nothing to do with LS? Thanks for any info.
  2. mistwang

    mistwang LiteSpeed Staff

    Code:
    Server Restart Request via Signal...
    Someone tell LSWS to restart by sending signal to the server process.
    How often does it happen? Is there any cron job restart LSWS regularly?

Share This Page