Randomly very long "Waiting for..." (on visitor's

Discussion in 'Bug Reports' started by Roman2K, Oct 7, 2005.

  1. Roman2K

    Roman2K New Member

    Hello,

    I have set up a Virtual Host with an FastCGI External Application as context for the URI "/". The application is the dispatch.fcgi of a Rails application. When I access the virtualhost by its domain, the Rails application works :).

    The problem is when I refresh a page or access another (of the app) following a link, it is sometimes, randomly, very long and does not respond at all with the "Waiting for mydomain.com" in the status bar of Firefox. I must do another refresh and it can randomly do the same thing or show the requested page.

    I think it is a bug of LiteSpeed. Do you have any idea of what is this problem ? What does it come from and how to solve it ?

    Thank you in advance.
  2. mistwang

    mistwang LiteSpeed Staff

    You can turn on debug logging by setting "Debug Level" to "high", you will find useful information there to help you identify the problem.

    And if you want, you can PM us a temp login to your server, we can take a look.

    George
  3. Roman2K

    Roman2K New Member

    Thank you mistwang, check your PMs.
  4. mistwang

    mistwang LiteSpeed Staff

    It is fault of ruby's fcgi extension, you can either use the pure ruby fcgi code or patch the ext/fcgi/fcgi.c, search for "FCGX_Finish", then add a line of code:
    Code:
    FCGX_Free( data->req, 1 );
    There might be other problems, like memory leak, in the fcgi extension. You can contact the author.

    And the ruby FCGI extension does not use persistent FCGI connection, and it requires establishing a new connection for each request, but the existing connection has not been properly closed by the C extension.
    Other web server like Apache or lighttpd does not take advantage of persistent connection either, so it appear OK for them.
  5. Roman2K

    Roman2K New Member

    Thank you a lot George, the patch works. You really deserve sincere congratulations for your work and support of LSWS.

Share This Page