rebuilding php5 with mysql

Discussion in 'Install/Configuration' started by karloff, Jul 22, 2008.

  1. karloff

    karloff New Member

    I have been trying to rebuild mysql (4.1) with php5 but keep getting the error

    this is what my config.log says
    can't find any info on this, can anyone suggest a fix?
  2. mistwang

    mistwang LiteSpeed Staff

    If you were building 64bit PHP binary, you should add "--with-libdir=lib64" option.
    With this option, seems the "--with-mysql=/usr" works without expanding mysql package under "/usr/local/mysql".
  3. karloff

    karloff New Member

    does this make sense?

    --with-mysqli --with-zlib --with-gd --enable-shmop --enable-track-vars --enable-sockets --enable-sysvsem --enable-sysvshm --enable-magic-quotes --enable-mbstring --with-iconv --with-mysql=/usr --with-mysql-sock=/var/lib/mysql/mysql.sock --enable-simplexml --with-libdir=lib64
  4. mistwang

    mistwang LiteSpeed Staff

    looks fine to me.
  5. karloff

    karloff New Member

    looks all good:)

    how can i test to see if the connection is there and is ok?

    my site still seems to be coming up blank therefore the connection must be broken.

    edit: just checked, phpmyadmin just verified that
  6. karloff

    karloff New Member

    sorted, added include_path = ".:/usr/local/lsws/lsphp5/lib/php" to my php.ini and a restart.

    cheers mistwang
  7. karloff

    karloff New Member

    mistwang, where did you get that info, i'm going to post some info on my blog which may be helpful to others:rolleyes:, however i would like to know the background to those great suggestions

    cheers
  8. mistwang

    mistwang LiteSpeed Staff

    Just notice that another forum user posts his PHP configuration parameter, I give it a try and it works.

Share This Page