recv_fd() failed

Discussion in 'Bug Reports' started by NC-Designs, Oct 30, 2011.

  1. NC-Designs

    NC-Designs New Member

    Since upgrading to 4.1.7 I have been getting this error creating about 500MB worth of logs within a few hours...

    Code:
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-30 21:11:21.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    
    Please help what is up here?
  2. mistwang

    mistwang LiteSpeed Staff

    It relates to the real time status page.
    Please send us the log file section just before it starts see if we can figure out something.
  3. NC-Designs

    NC-Designs New Member

    Hi mistwang, thanks for your speedy reply! Sorry mine wasn't so quick.

    Please see below log -

    Code:
    2011-10-31 11:10:12.191 [STDERR] PHP Warning:  Module 'PDO' already loaded in Unknown on line 02011-10-31 11:10:12.191 [STDERR] PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0PHP Warning:  Module 'PDO' already loaded in Unknown on line 0PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0PHP Warning:  Module 'PDO' already loaded in Unknown on line 0PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0PHP Warning:  Module 'PDO' already loaded in Unknown on line 0PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0PHP Warning:  Module 'SQLite' already loaded in Unknown on line 02011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    2011-10-31 11:10:13.000 [ERROR] recv_fd() failed, fd: -1, len: 0.
    
    Also, I have tried resolving these module already loaded errors - I am loading these extensions in via /usr/local/lib/php.ini - Does LiteSpeed then attempt to load again or something?
  4. webizen

    webizen New Member

    Likely these modules are already built in PHP. You may comment them out in php.ini.

  5. mistwang

    mistwang LiteSpeed Staff

    4.1.7 has been updated with extra code dealing with this issue. please give it a try if you want.
  6. NC-Designs

    NC-Designs New Member

    Thanks for your response. I will force download and reinstall this and see if it provides a fix. How come this has been rereleased as the same package rather than a 4.1.8?

    It's a little bit confusing!
  7. NC-Designs

    NC-Designs New Member

    Okay, completing this upgrade doesn't seem to have worked. Any other suggestions?

    Thanks,
    Chris.
  8. mistwang

    mistwang LiteSpeed Staff

    Do you still get recv_fd() failed error in the log? Does the problem starts immediately after upgrade or wait for a while?

    Are you using caccti integration to monitor the server?
  9. NC-Designs

    NC-Designs New Member

    I am still getting these logs yes, they are eating up about 2GB disk in a day. I'm not using Cacti to monitor the server nope and this issue starts about an hour or so after upgrade.
  10. NC-Designs

    NC-Designs New Member

    Any updates on this? I paid a hell of a lot of money on your software and would appreciate a response and maybe even some support.
  11. mistwang

    mistwang LiteSpeed Staff

    Please download and try 4.1.9 release packages. Just change the version number in the download link to get it.

Share This Page