Repeated update notification

Discussion in 'General' started by msolamm, Mar 12, 2012.

  1. msolamm

    msolamm New Member

    Hi,
    I keep receiving these messages from our server:
    I updated to 4.1.11 via the web interface (see attachment) and have restarted lsws, but am still receiving these messages to update to 4.1.10-ent. Note that I was already running 4.1.10 when these messages started about a week ago. Any suggestions, please?

    Attached Files:

  2. webizen

    webizen New Member

    check the permission and ownership of /usr/local/lsws/autoupdate directory and /usr/local/lsws/autoupdate/release and make sure LiteSpeed running user has write permission.
  3. msolamm

    msolamm New Member

    Hi,
    /usr/local/lsws/autoupdate is owned by lsadm and /usr/local/lsws/autoupdate/release is owned by the user nobody (with write permissions).
  4. webizen

    webizen New Member

    change the owner of /usr/local/lsws/autoupdate/release to be lsadm.
  5. msolamm

    msolamm New Member

    Hi,
    I believe that's done the trick. When I restarted lsws after changing ownership, I received an email notification for 4.1.11 (instead of 4.1.10, as before) and it prompted me to install 4.1.11 in the admin console.

    Any ideas why this happened? It was a clean install of 4.1.10 on our server, without any permissions having been changed.
  6. webizen

    webizen New Member

    don't think you need to restart lsws to make it effective.

    however, upgrade from web console should not affect ownership. it should be owned by lsadm (lsws admin user).

Share This Page