Request Timeout after 15 secs.

Discussion in 'General' started by slimak, Mar 5, 2007.

  1. slimak

    slimak New Member

    Hello,
    at one account I have installed Account Lab Plus. I have error like this below, when I create accounts in WHM by ACL:

    Code:
    Request Timeout
    
    This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'.
    
    Previously (before change from Apache to LSWS) it was ok. The error always appear after 15 seconds. I tried to set connection timeout to 120 seconds. I tried to change max_execution_time in PHP, but that also didn't help. When I created an empty PHP script with function sleep(60);, then it was ok. Do you have any idea, why this problem occur?
  2. mistwang

    mistwang LiteSpeed Staff

    Does the script takes long time to finish? It may not be a problem of timeout setting, maybe a missing PHP module or something.

    I think you need to turn on debug logging, and maybe strace the PHP process to find out what is the problem.
    Last edited: Mar 5, 2007
  3. slimak

    slimak New Member

    Answer

    It takes about 10-20 seconds to finish.
    I enabled debug logging, but there isn't anything interesting.
    I see that the whole lsws is restarting, when I try to execute that script.
    I did a strace: http://host8.xon.pl/strace
    Maybe the problem is in line:
    shmctl(1343619094, IPC_RMID, 0xbfffddb0) = -1 EINVAL (Invalid argument)
  4. mistwang

    mistwang LiteSpeed Staff

    I think it is a PHP problem, maybe some required PHP extension has not be inclded in lsphp binary, maybe you should check the configruation options in phpinfo() with Apache, then build your own lsphp binary with similar configuration options.

    For more information regarding building lsphp, please check out our wiki.

Share This Page