[Resolved] Confluence configuration problem

Discussion in 'Install/Configuration' started by john, Sep 15, 2010.

  1. john

    john New Member

    Hi Gurus

    I am configuring Confluence on Centos 4.4 .Everything seems fine except this gives the following perl error.


    Can't locate Digest/SHA.pm in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl .) at (eval 3) line 3.

    I am a new bee to perl debugging.Please help to resolve the problem.

    Thanks
    Last edited by a moderator: Sep 23, 2010
  2. NiteWave

    NiteWave Administrator

    try
    yum install perl-Digest-SHA1.i386

    not sure it'll help or not
  3. john

    john New Member

    This package is already installed.

    Thanks
  4. gorishanker

    gorishanker New Member

    At my pc, with confluence this is working.

    At my pc, with confluence this is working but with with a perl script i am getting same error.
    -----
    Can't locate Digest/SHA.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at (eval 3) line 3.
    -----
  5. mistwang

    mistwang LiteSpeed Staff

    check where those files are installed with

    rpm -ql perl-Digest-SHA1.i386

    and make sure the include path contain those directories.
  6. gorishanker

    gorishanker New Member

    At my pc, with confluence this is working.

    Thanks mistwang for instant reply,

    -----
    perl-Digest-SHA1-2.07-5 is installed at '

    /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi/Digest/SHA1.pm
    /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi/auto/Digest/SHA1/SHA1.bs
    /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi/auto/Digest/SHA1/SHA1.so
    /usr/share/man/man3/Digest::SHA1.3pm.gz

    Now where to check for assurance of 'the include path contain those directories'.
    -----
  7. mistwang

    mistwang LiteSpeed Staff

    The perl version does not match, you may have to install the perl module via CPAN, google how to do it.
  8. gorishanker

    gorishanker New Member

    At my pc, with confluence this is working.

    Yes,
    'cpan install Digest::SHA' fixes the problem.

    Thanks.:)

Share This Page