[RESOLVED] LSAPI 5.2 register_long_arrays

Discussion in 'Bug Reports' started by AndrewT, Feb 5, 2010.

  1. AndrewT

    AndrewT Member

    With LSAPI 5.2 and PHP 5.2.12 register_long_arrays = On does not work.

    With LSAPI 4.10 and PHP 5.2.12 register_long_arrays = On works as intended.
    Last edited by a moderator: Feb 10, 2010
  2. mistwang

    mistwang LiteSpeed Staff

    You can turn it on with php_value in .htaccess.
    register_long_arrays is going to disappear in PHP anyway.
  3. AndrewT

    AndrewT Member

    I've not tested setting it in the .htaccess file using php_value but I don't see how that is even relevant nor can I imagine why that should give different results.

    With it set to ON in the php.ini file (and showing up as such in phpinfo()), it does not work with LSAPI 5.2. It works as intended with LSAPI 4.10.

    register_long_arrays is set to be removed in PHP 6. That's quite a ways off for most (shared) hosting environments where this setting can actually be a concern.
  4. AndrewT

    AndrewT Member

    Using "php_value register_long_arrays 1" in a .htaccess file does in fact make it work with LSAPI 5.2 even though the setting is already explicitly enabled in the php.ini file.

    This still leaves the bug as initially reported. The setting in the php.ini file has no impact, register_long_arrays doesn't work whether it is enabled or not in the php.ini.
  5. mistwang

    mistwang LiteSpeed Staff

    It is intentional. Will change the implementation to make php.ini work.
    Last edited: Feb 5, 2010
  6. AndrewT

    AndrewT Member

    Thank you!
  7. mistwang

    mistwang LiteSpeed Staff

    please check PHP LSAPI 5.3
  8. colorprint

    colorprint New Member

    I have installed the 5.3 but register_long_arrays still not works :(
  9. AndrewT

    AndrewT Member

    I can also confirm that it still does not work.
  10. mistwang

    mistwang LiteSpeed Staff

    Sorry, made a mistake, please download the code and try again.
  11. colorprint

    colorprint New Member

    It works now, thanks!
  12. AndrewT

    AndrewT Member

    Confirmed - it works. Thank you.

Share This Page