[Resolved] php 5.3.3 with curl not working

Discussion in 'Install/Configuration' started by sicute, Oct 7, 2010.

  1. sicute

    sicute New Member

    hi ..
    i try recomplier php become 5.3.3 and curl , i using compile php in admin section here my config :

    './configure' '--prefix=/usr/local/lsws/lsphp5' '--with-mysqli' '--with-zlib' '--with-gd' '--enable-shmop' '--enable-track-vars' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-magic-quotes' '--enable-mbstring' '--with-iconv' '--enable-curl' '--enable-suhosin' '--with-litespeed'

    i check curl not active also i have error notice
    Warning: phpinfo() [function.phpinfo]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Los_Angeles' for 'PDT/-7.0/DST' instead in /usr/local/lsws/DEFAULT/html/phpinfo.php on line
    Last edited by a moderator: Oct 7, 2010
  2. NiteWave

    NiteWave Administrator

    the warning is irrelative to curl. add
    date.timezone="America/Los_Angeles" etc will eliminate the warning message.

    there should be no problem for 5.3.3 with curl -- I just built it a few days ago.

    please record the error message during php build.
  3. sicute

    sicute New Member

    here some log complie

    Thank you for using PHP.

    Notice: Following unknown configure options were used:

    --enable-track-vars
    --enable-curl
    --enable-openssl
    --with-curl-dir=..
    --enable-suhosin

    Check './configure --help' for available options


    Libraries have been installed in:
    /usr/local/lsws/phpbuild/php-5.3.3/suhosin-0.9.32.1/modules

    If you ever happen to want to link against installed libraries
    in a given directory, LIBDIR, you must either use libtool, and
    specify the full pathname of the library, or use the `-LLIBDIR'
    flag during linking and do at least one of the following:
    - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
    during execution
    - add LIBDIR to the `LD_RUN_PATH' environment variable
    during linking
    - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
    - have your system administrator add LIBDIR to `/etc/ld.so.conf'

    See any operating system documentation about shared libraries for
    more information, such as the ld(1) and ld.so(8) manual pages.
    ----------------------------------------------------------------------

    Build complete.
    Don't forget to run 'make test'.

    Installing Suhosin extension
    Installing shared extensions: /usr/local/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20090626/
    chown -R lsadm:lsadm /usr/local/lsws/phpbuild/php-5.3.3/suhosin-0.9.32.1

    ==============================================
    Suhosin extension build complete
    ==============================================
    Wed Oct 6 20:04:55 PDT 2010

    **COMPLETE**


    i check in my script php

    Checking environment...

    * PHP version: 5.3.3
    * cURL version: not available

    Environment check failed


    you can check direct my phpinfo in pojokdomain dot us/phpinfo.php

    i using ubuntu 10 update online fresh

    I try downgrade php bellow php 5.3.3 , not working same proble with autoconf 2.6


  4. NiteWave

    NiteWave Administrator

    yes, the error message tell the cause:
    checked the PHP document,
    http://www.php.net/manual/en/curl.installation.php

    no --enable-curl option, instead, it's --with-curl
  5. sicute

    sicute New Member

    same curl not active event using --enable-curl or --with-curl-dir=/usr/lib/libcurl.a
    may be i try manualy complie without using litespeed compiler.
  6. NiteWave

    NiteWave Administrator

    to be clear, must include
    and not use
    there are just Unknown options.
  7. sicute

    sicute New Member

    thanks now is working after 2 day

    her my config

    /configure' '--prefix=/usr/local/lsws/lsphp5' '--with-mysqli' '--with-zlib' '--with-gd' '--enable-shmop' '--enable-track-vars' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-magic-quotes' '--enable-mbstring' '--with-iconv' '--enable-curl' '--with-curl' '--enable-suhosin' '--with-litespeed'
  8. agriz

    agriz New Member

  9. webizen

    webizen New Member

    You may have path/to/css hardcode in the page so that those css files will be missing when serve from :2080.

    to troubleshoot long page loading, use firebug to get the loading breakdown of each resource of the page to see the bottleneck.

Share This Page