[Resolved] ProxyPass Configuration using Proxy in Litespeed

Discussion in 'Install/Configuration' started by Elik, May 11, 2010.

  1. Elik

    Elik New Member

    Hello,

    I have been trying to setup the tomcat proxy so that person can use tomcat to pass it to Tomcat. I have setup in the External App the setting for Tomcat to be proxied at port 8080 using Webserver Setting.

    Then I add in the .htaccess this line:

    RewriteEngine On
    RewriteRule ^/(.*)$ http://127.0.0.1:8080/$1 [L,P,QSA]

    But it does not work, since it give error 500 when I tried it. I used the information I found from the forum to do the Reverse Proxy so I can redirect requests to tomcat for servlets, and such, and it is not working properly as it should be for it. So...any help here?

    Note that it fails since it could not find the file, home.do in the directory, but tomcat picks it up when tried directly, but not from litespeed proxy itself.

    Here is the reference link to the other post, which I used to setup the Tomcat Proxy which it did not work for it. http://www.litespeedtech.com/support/forum/showthread.php?t=2879
    Last edited by a moderator: May 12, 2010
  2. NiteWave

    NiteWave Administrator

    Maybe you've missed the last post in that thread?

    repost it here:
  3. Elik

    Elik New Member

    Last edited: May 11, 2010
  4. NiteWave

    NiteWave Administrator

    Code:
    I have setup in the External App the setting for Tomcat to be proxied at port 8080 using Webserver Setting.
    assume the external app name is tomcat_backend. Please try following instead:
    Code:
    RewriteEngine On
    RewriteRule (.*) http://tomcat_backend/$1 [L,P,QSA]
    I did similar test locally, and passed.
  5. Elik

    Elik New Member

    Thanks

    Now we getting somewhere with this. Now I able to get it passed to Tomcat with that example. Now I gotta see how to get tomcat to recognize the home.do as well for it to load.

    Nevermind, seems the client been mucking around with it, causing it not to load at this point, but the tomcat proxy is working properly now. I appreciate the help!
    Last edited: May 11, 2010

Share This Page