security

Discussion in 'Feedback/Feature Requests' started by Dani, Nov 29, 2005.

  1. jnrey

    jnrey New Member

    Works here. What's wrong now then.
  2. viettechorg

    viettechorg New Member

    Can you please tell me step-by-step how to do it? Mine shows default errors even i changed them.
  3. jordan

    jordan New Member

    Well got the trial enterprise version so far, but did not see it.
  4. jnrey

    jnrey New Member

    Bad Request 400 shows "Powered By LiteSpeed Web Server"

    Hi Mistwang. Although I have done my own 400.html page with server setting "Hide Full Header" and e.g. my own 404.html does show, this message below is not replaced by my 400.html page. Although the title below is "400 Bad Request", and my message 400 is maintained under VH - General - Cust Error Pages. Also, when I enter the direct <site path>.400.html, my 400 does come up properly. How can I replace this message below ? It is triggered when I enter http:<site>:443. Many thanks.

    HTTPS is required

    This is an SSL protected page, please use the HTTPS scheme instead of the plain HTTP scheme to access this URL.

    Hint: The URL should starts with https://

    Powered By LiteSpeed Web Server
    http://www.litespeedtech.com

    <html><head><title>400 Bad Request</title></head><body>
    <h2>HTTPS is required</h2>
    <p>This is an SSL protected page, please use the HTTPS scheme instead of the plain HTTP scheme to access this URL.<br />
    <blockquote>Hint: The URL should starts with <b>https</b>://</blockquote> </p>
    <hr />
    Powered By LiteSpeed Web Server<br />
    <a href='http://www.litespeedtech.com'><i>http://www.litespeedtech.com</i></a>
    </body></html>
  5. jnrey

    jnrey New Member

    Hi again Mistwang. Any clue ?
  6. mistwang

    mistwang LiteSpeed Staff

    In our upcoming 4.0 release, I will added server wide custom page.
  7. anewday

    anewday Moderator

    Great, something I wanted for a while. How about on a vhost level too?
  8. mistwang

    mistwang LiteSpeed Staff

    vhost level custom error page is available now, it is just that a 400 error page does not below to any vhost as LSWS does not finish parsing the request at all. so it has to be set at server level.
  9. netnoise

    netnoise New Member

    I just downloaded the beta package but couldn't find this option. BTW: I find it would be much more convenient if the built-in error pages would appreciate the "Server Signature" setting...
  10. mistwang

    mistwang LiteSpeed Staff

    Please wait for beta 2.

Share This Page