Setting index options from cPanel or .htaccess not working

Discussion in 'Apache Migration/Compatibility' started by Rob T, Jul 5, 2007.

  1. Rob T

    Rob T New Member

    I'm running LSWS with cPanel in apache compatibility mode. In cPanel, users have the options to turn on/off automatically generated directory indexes, and they also have some options on how they display. Basically what this does is it tells cPanel to create a .htaccess file in the directory in question that turns indexes on, and sets any options - a sample would look something like this:

    Options All Indexes
    IndexOptions -FancyIndexing

    However, no indexes are displayed when viewing the site using LSWS as the web server.

    1 - It there any kind of temporary workaround in place now that will allow indexes to be displayed on a single apache virtual host?

    2 - Are there plans to support this in the future via the .htaccess entries created by cPanel?

    Thanks!

    Rob T
  2. mistwang

    mistwang LiteSpeed Staff

    Please checkout our cPanel Wiki for work around for the directory indexing problem. It is a issue with PHP "open_basedir" configuration.
    -FancyIndexing will be supported later.

Share This Page