SNMP + Cacti Install = initscripts problem

Discussion in 'Install/Configuration' started by jayjaybaby, Oct 19, 2008.

  1. jayjaybaby

    jayjaybaby New Member

    I am having a problem installing LiteSpeed SNMPD Bridge + Cacti Graphing. Below is when I ran yum install net-snmp-utils via ssh, the error is in bold below aswell.



    =============================================================================
    Package Arch Version Repository Size
    =============================================================================
    Installing:
    net-snmp-utils i386 1:5.3.1-24.el5_2.1 updates 182 k
    Installing for dependencies:
    dmidecode i386 1:2.7-1.28.2.el5 base 62 k
    libsysfs i386 2.0.0-6 base 46 k
    lm_sensors i386 2.10.0-3.1 base 494 k
    net-snmp i386 1:5.3.1-24.el5_2.1 updates 698 k
    net-snmp-libs i386 1:5.3.1-24.el5_2.1 updates 1.2 M

    Transaction Summary
    =============================================================================
    Install 6 Package(s)
    Update 0 Package(s)
    Remove 0 Package(s)

    Total download size: 2.7 M
    Is this ok [y/N]: y
    Downloading Packages:
    Running rpm_check_debug
    ERROR with rpm_check_debug vs depsolve:
    Package initscripts needs ethtool >= 1.8-2, this is not available.
    Package initscripts needs mingetty, this is not available.
    Package initscripts needs module-init-tools, this is not available.
    Complete!





    Any suggestions on getting this to install properly?

    Thanks
  2. mistwang

    mistwang LiteSpeed Staff

    your yum system is broken, check your /etc/yum.conf, try disabling the "exclude" list temporarily.
  3. jayjaybaby

    jayjaybaby New Member

    Alright, I commented out / disabled the "exclude" line from /etc/yum.conf and I still get the same error. My yum.conf looks like the following:

    [main]
    cachedir=/var/cache/yum
    keepcache=0
    debuglevel=2
    logfile=/var/log/yum.log
    distroverpkg=redhat-release
    tolerant=1
    exactarch=1
    obsoletes=1
    gpgcheck=1
    plugins=1

    # Note: yum-RHN-plugin doesn't honor this.
    metadata_expire=1h

    # Default.
    # installonly_limit = 3

    # PUT YOUR REPOS HERE OR IN separate files named file.repo
    # in /etc/yum.repos.d
    # exclude=apache* httpd* mod_* mysql* MySQL* da_* *ftp* exim* sendmail* php* bind-chroot*



    Any other ideas on what the issue is?

    Thanks
  4. mistwang

    mistwang LiteSpeed Staff

    you can try explicitly install those missing rpm

    yum install ethtool mingetty module-init-tools
  5. jayjaybaby

    jayjaybaby New Member

    I actually got the issue fixed by adding

    rpm_check_debug=False

    to my /etc/yum.conf

    Thanks for your help.

Share This Page