[solved] 503 Service Unavailable ON WP > wp-admin/options.php

Discussion in 'Install/Configuration' started by pooyan, Jul 2, 2012.

  1. pooyan

    pooyan New Member

    Hello,

    After i updated lsws, on all wordpress sites and on all admin pages etc: wp-admin/options.php and ... when i enter submit display :

    503 Service Unavailable
    The server is temporarily busy, try again later! Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!
    Last edited by a moderator: Jul 10, 2012
  2. webizen

    webizen New Member

    pls check error log (enable debug loglevel) and see any clue as to why the 503 error.
  3. pooyan

    pooyan New Member

    who can i do check error log also enable debug loglevel ?
  4. webizen

    webizen New Member

    Admin Console => Configuration => Server => Log

    Log Level: DEBUG
    Debug Level: Low
  5. pooyan

    pooyan New Member

    For check error log need i see /usr/local/apache/logs/error_log ?
  6. webizen

    webizen New Member

    That's the one.
  7. pooyan

    pooyan New Member

    Latest error log:
    2012-07-04 15:51:37.274 [NOTICE] Loading LiteSpeed/4.1.12 Enterprise ...
    2012-07-04 15:51:37.275 [DEBUG] Daemonized!
    2012-07-04 15:51:37.475 [NOTICE] [ADMIN] server socket: uds://usr/local/lsws/admin/tmp/admin.sock.7592
    2012-07-04 15:51:37.475 [NOTICE] Loading configuration from /usr/local/lsws/conf/httpd_config.xml ...
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [127.0.0.1:443]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [127.0.0.1:80]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.112:443]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.112:80]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.122:443]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.122:80]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.123:443]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.123:80]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.124:443]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.124:80]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.125:443]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [176.9.64.125:80]
    2012-07-04 15:51:37.476 [NOTICE] Recovering server socket: [*:7080]
    2012-07-04 15:51:37.476 [NOTICE] [config] chroot is disabled.
    2012-07-04 15:51:37.476 [INFO] old priority: -19, new priority: -19
    2012-07-04 15:51:37.476 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2012-07-04 15:51:37.477 [INFO] Start listen socket [/usr/local/lsws/admin/cgid/cgid.sock.343].
    2012-07-04 15:51:37.477 [NOTICE] [PID: 22853]: start cgid: 22855, /usr/local/lsws/bin/httpd
    2012-07-04 15:51:37.477 [WARN] [config:server:tuning] invalid value of <maxReqBodySize>:2047M, use default=2097152
    2012-07-04 15:51:37.477 [DEBUG] Reuse current listener [adminListener].
    2012-07-04 15:51:37.477 [WARN] [config:server:listener] No listener is available for normal virtual host!
    2012-07-04 15:51:37.477 [NOTICE] The maximum number of file descriptor limit is set to 21000.
    2012-07-04 15:51:37.477 [DEBUG] [/usr/local/lsws/admin/conf/admin_config.xml:1] processing direcitve: php_admin_value expose_php 0.
    2012-07-04 15:51:37.477 [DEBUG] [/usr/local/lsws/admin/conf/admin_config.xml:1] add PHP config: expose_php 0
    2012-07-04 15:51:37.477 [DEBUG] [/usr/local/lsws/admin/conf/admin_config.xml:2] processing direcitve: php_admin_flag allow_url_fopen On.
    2012-07-04 15:51:37.477 [DEBUG] [/usr/local/lsws/admin/conf/admin_config.xml:2] add PHP config: allow_url_fopen On
    2012-07-04 15:51:37.477 [DEBUG] [/usr/local/lsws/admin/conf/admin_config.xml:3] processing direcitve: php_admin_value session.save_path '/usr/local/lsws//admin/tmp'.
    2012-07-04 15:51:37.477 [DEBUG] [/usr/local/lsws/admin/conf/admin_config.xml:3] add PHP config: session.save_path '/usr/local/lsws//admin/tmp'
    2012-07-04 15:51:37.477 [DEBUG] Associates [_AdminVHost] with [*:7080] on hostname/IP [*] succeed!
    2012-07-04 15:51:37.477 [NOTICE] [config] Cache function requires a 2-CPU license or above.
    2012-07-04 15:51:37.477 [WARN] [config:server:epsr:lsphp5] Improper configuration: the value of PHP_LSAPI_CHILDREN should not be less than 'Max connections', 'Max conn$
  8. NiteWave

    NiteWave Administrator

    please post your ext App lsphp5's settings here
  9. pooyan

    pooyan New Member

    Name lsphp5
    Address uds://tmp/lshttpd/lsphp5.sock
    Max Connections 2000
    Environment PHP_LSAPI_MAX_REQUESTS=500 PHP_LSAPI_CHILDREN=35
    Initial Request Timeout (secs) 400
    Retry Timeout (secs) 0
    Persistent Connection Yes
    Connection Keepalive Timeout 0
    Response Buffering Yes
    Auto Start Yes
    Command $SERVER_ROOT/fcgi-bin/lsphp5
    Back Log 100
    Instances 1
    suEXEC User Empty
    suEXEC Group Empty
    Run On Start Up None Set
    Max Idle Time 10
    Priority 0
    Memory Soft Limit (bytes) 1200M
    Memory Hard Limit (bytes) 1000M
    Process Soft Limit 1000
    Process Hard Limit 800
  10. NiteWave

    NiteWave Administrator

    looks the settings has been modified heavily from the default one, it may be the cause of various strange behavior.
    Max Connections 2000
    LSAPI_CHILDREN=35
    ==>they should match. please change "Max Connections" back to 35

    Initial Request Timeout (secs) 400
    ==>default one is 60. any reason to set so large -- 400?

    Connection Keepalive Timeout 0
    ==>please set a value other than 0: -1, 1, 5, 10 ... etc, or just Not Set it.

    Response Buffering Yes
    ==> set it to default "No"

    Max Idle Time 10
    ==> too small ? increase it or leave it blank.

    Memory Soft Limit (bytes) 1200M
    Memory Hard Limit (bytes) 1000M
    ==>soft limit should <= hard limit

    Process Soft Limit 1000
    Process Hard Limit 800
    ==>same as above: soft limit should <= hard limit
  11. pooyan

    pooyan New Member

    Thanks for replay,

    I changed settings and saved then restarted lsws but problem not fixed,
    Could you please help me?
  12. webizen

    webizen New Member

    you need to search error_log for 503 error and check the entries around to see any details of the error.
  13. pooyan

    pooyan New Member

    I checked all error_log and not found any error for 503
    PLEASE help me.
  14. webizen

    webizen New Member

    What's your server env (OS version, wp version, cpanel, etc)? Did you build matching PHP?
  15. pooyan

    pooyan New Member

    OS: Centos 5.8 64
    WP latest version
    cPanel latest version
    PHP 5.2
    This server working +1year fine but after i removed /tmp files and folder ( rm -rf /tmp/* ) this problem is created.
  16. webizen

    webizen New Member

    Litespeed relies on /tmp/lshttpd to be functional. hence 'rm -rf /tmp/*' would cause problem. Pls re-create /tmp/lshttpd with correct ownership (751 nobody.nobody).
  17. pooyan

    pooyan New Member

    I checked, there is /tmp/lshttpd with correct ownership (751 nobody.nobody).
    Problem still here. Pls help me.
  18. webizen

    webizen New Member

    try the latest 4.1.13.
  19. pooyan

    pooyan New Member

    Please wait when processing your requests ...Done!
    lsws updated, i restarted lsws but problem not fixed.
  20. pooyan

    pooyan New Member

    Pls help me.

Share This Page