[solved] Auto Index is disabled for ....

Discussion in 'General' started by pardis, Oct 18, 2011.

  1. pardis

    pardis Member

    Hello :

    Please see this URL :
    http://www.form2online.com/ (403 Forbidden)

    when i check server log I see following :
    Auto Index is disabled for [/home/formonli/public_html/up/], access denied

    this problem occurred only for this customer , How can resolve this ??

    Best regards
    Last edited by a moderator: Oct 20, 2011
  2. NiteWave

    NiteWave Administrator

    what version of lsws ?
  3. pardis

    pardis Member

    last version 4.1.6
  4. NiteWave

    NiteWave Administrator

    is /up a folder under document root ?
  5. pardis

    pardis Member

    yes ... /public_html/up
  6. NiteWave

    NiteWave Administrator

    is there up/.htaccess in it? if exists, what's the content?
  7. pardis

    pardis Member

    No .htaccess found in /up folder.
  8. NiteWave

    NiteWave Administrator

    what's the permission of /up?

    #ls -ald public_html
    #ls -ald public_html/up
  9. pardis

    pardis Member

    drwxr-xr-x 10 formonli formonli 4096 Oct 18 10:28 up/
    drwxr-x--- 33 formonli nobody 4096 Oct 18 11:00 public_html/
  10. NiteWave

    NiteWave Administrator

    how about

    #chgrp nobody up
  11. pardis

    pardis Member

    what is your means about "chgrp nobody up" ?
  12. NiteWave

    NiteWave Administrator

    change folder "up"'s group to nobody, same as public_html

    or

    #chgrp nobody public_html/up
  13. pardis

    pardis Member

    done.
    but no positive result.
  14. Karl

    Karl New Member

    I apologise for digging an old thread up, but did you get a resolution to this? we're seeing similar issues:

    1) some sites work perfect
    2) some work okay for the root, but folders don't
    3) some don't work at all

    All the sites/folders have an index.php file in them. The server has Index Files set as: index.php, index.html

    The sites/folders that don't work, if we add:

    DirectoryIndex index.php index.html

    to the .htaccess then they will work - but we shouldn't need to add this, as it's set at the server level!

    Thanks,
  15. pardis

    pardis Member

    Hi Karl :
    Thank you of your useful comment , I did check user .htaccess file and see :
    DirectoryIndex portal.html

    web server look into folder portal.html and not found in that folder and error occur. i change that line into :
    DirectoryIndex portal.html index.php index.htm
    and problem occur.
  16. mistwang

    mistwang LiteSpeed Staff

    problem occur? after changing DirectoryIndex, or it is fixed?
  17. pardis

    pardis Member

    fixed after change DirectoryIndex.
  18. mistwang

    mistwang LiteSpeed Staff

    sometimes, the index file or autoindex was overridden by .htaccess somewhere. try switching back Apache temporarily, if apache is the same, it is a configuration problem, if not, it is a compatibility issue, we will look into it.
  19. Karl

    Karl New Member

    Hi,

    There is no Apache on this server - but the same vhosts work fine on the server the sites are being copied from (for ease of transition the Apache vhost config files have been used - but only those, not the rest of the Apache config). All the vhosts follow the exact same settings with the exception of document roots and log file locations - yet some work, and others do not and those that work, in most the index.php won't work as default inside directories. I've checked the .htaccess for DirectoryIndex statements over-riding - there are non.

    Thanks,
  20. mistwang

    mistwang LiteSpeed Staff

    Please give latest 4.1.6 a try, and if problem persist, we can do more investigation if you can provide a test server that can be taken down for a while.

Share This Page