[solved] Can't figure out lsphp suexec

Discussion in 'General' started by skizzerz, Jan 15, 2014.

  1. skizzerz

    skizzerz New Member

    For some reason, litespeed isn't honoring my suexec settings and is instead running PHP as the same uid/gid as the main server application, and I cannot figure out why.

    Here's my current setup:
    Litespeed 4.2.6, PHP 5.5.7 (lsapi 6.6), Ubuntu 12.04, no control panels
    On the virtual host, I have ExtApp Set UID Mode set to "DocRoot UID". The document root is owned by www-data (still in the process of migrating from apache+mod_php, and I want to move to a suexec setup to better encapsulate each application and to reduce possible damage in the case of an exploit), and lshttpd is running as nobody. lsphp5 is running as root, so it can properly setuid to whatever it needs to, however it seems to be changing to nobody instead of www-data. The logs provide no useful information, even with debug logging enabled.

    Any ideas of where I should start looking?
    Last edited by a moderator: Jan 16, 2014
  2. skizzerz

    skizzerz New Member

    Figured it out.

    I had the Script Handler set to use the server's lsphp5 process. Instead I needed to add a new lsapi socket in External Applications and then set the script handler to use that customized one instead.
  3. NiteWave

    NiteWave Administrator

    great. Thanks for update.

Share This Page