[Solved] Compiling PHP 5.3.6 with LSAPI ::problem::

Discussion in 'PHP' started by flowcubano, May 17, 2011.

  1. flowcubano

    flowcubano New Member

    Hello

    I try to compile php to PHP 5.3.6 from litespeed panel but I get this error:
    (I'm use 8-CPU Lease LSWS Enterprise, Version 4.1 and I use Plesk 10)

    Code:
    checking whether time.h and sys/time.h may both be included... yes
    checking for working alloca.h... (cached) yes
    checking for alloca... (cached) yes
    checking for 8-bit clean memcmp... yes
    checking for stdarg.h... (cached) yes
    checking for mcrypt support... no
    checking for MSSQL support via FreeTDS... no
    checking for MySQL support... no
    checking for specified location of the MySQL UNIX socket... no
    checking for MySQLi support... yes
    checking whether to enable embedded MySQLi support... no
    checking for mysql_set_server_option in -lmysqlclient... no
    configure: error: wrong mysql library version or lib not found. Check config.log for more information.
    **ERROR** Could not configure PHP build
    Last edited: May 17, 2011
  2. NiteWave

    NiteWave Administrator

  3. flowcubano

    flowcubano New Member

    Thank you, NiteWave
  4. smartcard

    smartcard New Member

    Please let me know to which file I should include the above line (--with-mysql=mysqlnd --with-mysqli=mysqlnd)
  5. webizen

    webizen New Member


    "--with-mysql=mysqlnd --with-mysqli=mysqlnd" are the options to use in the php compilation stage (build/compile lsphp in LSWS).

Share This Page