[solved] cPanel 11.32 and Litespeed

Discussion in 'General' started by Alfa-Host, Feb 23, 2012.

  1. Alfa-Host

    Alfa-Host New Member

    Hello,

    I use cpanel 11.32 + litespeed 4.1.11 + cloudlinux 6 with enable suEXEC but lsphp5 process run as nobody !

    Thanks.
    Last edited by a moderator: Feb 24, 2012
  2. mistwang

    mistwang LiteSpeed Staff

    Please test it with a simple PHP script running "id" command to verify it.
    Is it a new installation? Does it only happen with 4.1.11? have you tried with older release?
  3. Alfa-Host

    Alfa-Host New Member

    first i see this problem with 4.1.10 then upgrade to 4.1.11 .
  4. mistwang

    mistwang LiteSpeed Staff

    You need to verify it with "id" command in a PHP script.
    Common shared script are running as nobody, like our directory index script, it is normal to see some PHP process running as nobody, however, it does not mean that all scripts were running as nobody, PHP script under user's public_html directory should run as the user own the file.
  5. Alfa-Host

    Alfa-Host New Member

    Before update to cPanel 11.32 , This issue did not exist !

    after update to cPanel 11.32 i see this issue then upgrade litespeed from 4.1.10 to 4.1.11 .

    with cPanel 11.30 issue did not exist .
  6. mistwang

    mistwang LiteSpeed Staff

    We have 11.32 in our lab as well, but we do not have this issue.
    Are you sure that suPHP is enabled in cPanel? switch back to Apache see if you have PHP running as the desired user id.
    If you are sure that apache work properly, but LSWS does not, please contact bug@litespeed... we may need to login to your server to take a look.
  7. Alfa-Host

    Alfa-Host New Member

    solved with this commend :
    Code:
    /usr/local/cpanel/bin/rebuild_phpconf 5 none suphp 1
    Probably because php default config was DSO , in httpd.conf was not written OWNER and GROUP of vhosts !

    Thanks.

Share This Page