[solved] [cPanel] After LiteSpeed installation /whm-server-status gives a 404 error

Discussion in 'Install/Configuration' started by georgetasioulis, Dec 7, 2011.

  1. georgetasioulis

    georgetasioulis New Member

    Hello,

    I have a cPanel server WHM 11.30.5 (build 2) w/ CloudLinux 5.7 and yesterday I installed LiteSpeed server on it.

    Although I can confirm from my logs that /whm-server-status was giving proper output before with Apache, right after installing LiteSpeed it gives a 404 error.

    Code:
    127.0.0.1 - - [07/Dec/2011:10:55:01 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:10:55:04 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:10:59:12 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:00:01 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:11:00:04 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:04:13 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:05:01 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:11:05:02 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:09:13 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:10:01 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:11:10:03 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:14:14 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:15:01 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:11:15:03 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:19:16 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:20:01 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:11:20:03 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:24:17 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:25:01 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:11:25:03 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:11:29:17 +0000] "GET / HTTP/1.1" 200 111
    I guess it's normal behavior but is there any similar directive I can add to LiteSpeed in order to fix this? In Apache I had
    Code:
    root@hydrogen [/]# grep -A 5 whm-server-status /usr/local/apache/conf/httpd.conf
    <Location /whm-server-status>
        SetHandler server-status
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Location>
    Otherwise can I somehow disable whatever is calling /whm-server-status every five minutes so that my access-log isn't filling up?

    PS: I'm seeing the above 404 errors on my /usr/local/apache/logs/access_log file, although when I curl localhost I get server by LiteSpeed.
    Code:
    root@hydrogen [/]# curl -i http://localhost/whm-server-status 
    HTTP/1.1 404 Not Found
    ----> Date: Wed, 07 Dec 2011 [B]12:25:48[/B] GMT
    Server: LiteSpeed
    Connection: close
    Content-Type: text/html
    Content-Length: 1979
    Code:
    root@hydrogen [/]# tail /usr/local/apache/logs/access_log 
    127.0.0.1 - - [07/Dec/2011:12:15:03 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:12:19:27 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:12:20:01 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:12:20:03 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:12:24:28 +0000] "GET / HTTP/1.1" 200 111
    127.0.0.1 - - [07/Dec/2011:12:24:55 +0000] "GET /whm-server-status HTTP/1.1" 404 1979
    127.0.0.1 - - [07/Dec/2011:12:25:02 +0000] "GET /whm-server-status HTTP/1.1" 404 1970
    127.0.0.1 - - [07/Dec/2011:12:25:03 +0000] "GET / HTTP/1.1" 200 111
    ----> 127.0.0.1 - - [07/Dec/2011:[B]12:25:48[/B] +0000] "GET /whm-server-status HTTP/1.1" 404 1979
    Something tells me I may have mixed things up a bit :p
    Last edited by a moderator: Dec 8, 2011
  2. mistwang

    mistwang LiteSpeed Staff

    LiteSpeed does not support Apache's status page, that's normal.
  3. webizen

    webizen New Member

    to get rid of "/whm-server-status", just comment out dcpumon cronjob.
  4. georgetasioulis

    georgetasioulis New Member

    Thanks a lot, that did the trick :)

Share This Page