[solved] domlog

Discussion in 'General' started by stairmaster, Oct 14, 2011.

  1. stairmaster

    stairmaster New Member

    Hi,
    I am having problems with our domlog filling up our disk.

    The domlog for our largest domain on our server is producing 2Gb domlog files each day.
    After a few days our server is reaching maximum disk capacity due to these files. I have to manually delete them every couple days.

    I don't know where to set the domlog rotation details.

    In litespeed admin > server > log > keep days
    I have set it to 1, so that it only keeps one day.

    And then I restarted litespeed. But that didn't make any difference.

    Is there somewhere else I need to change this? We are running WHM/cpanel too.
    Last edited by a moderator: Oct 17, 2011
  2. NiteWave

    NiteWave Administrator

    since your are running WHM/cpanel, apache's httpd.conf is read and parsed.
    won't work in this case.

    please google "apache log rotation" for solution, and I believe cPanel has good solution for it.
  3. stairmaster

    stairmaster New Member

    Thanks, I have turned off all stats programs in WHM (cpanel) - that seems to have stopped the domlogs from getting bigger.
  4. stairmaster

    stairmaster New Member

    In httpd.conf I commented out the lines that wrote the domlogs.
    I then restarted apache and litespeed to see if httpd.conf would get overwritten but it didn't. And the domlogs aren't being written to.
  5. mistwang

    mistwang LiteSpeed Staff

    You'd better changing cPanel's vhost template, otherwise, cPanel may overwrite the change when need to regenerate httpd.conf.

Share This Page