[solved] Dual PHP 5.2/5.3 on cPanel/WHM

Discussion in 'Install/Configuration' started by webhosting, Oct 10, 2011.

  1. webhosting

    webhosting New Member

    Can someone share clear step by step instructions for setting up php 5.2/5.3 in dual mode so we can select them either/or on a cpanel/whm vps server.

    Whenever I compile php from Litespeed 5.2.x, and then try to compile 5.3.x with different install path, it overwrites 5.2.x as default...

    Thank you.
    Last edited by a moderator: Oct 10, 2011
  2. NiteWave

    NiteWave Administrator

    please paste output here:
    #ls -l /usr/local/lsws/fcgi-bin
  3. webhosting

    webhosting New Member

    here is the output.
  4. NiteWave

    NiteWave Administrator

    per the output, lsphp5 is just a symbol link, the lsphp you built lsphp-5.3.8,lsphp-5.2.17 are all there.

    when you want 5.2.17 as default lsphp5, after build 5.3.x, run

    #cd /usr/local/lsws/fcgi-bin
    #ln -sf lsphp-5.2.17 lsphp5

    then restart lsws
  5. webhosting

    webhosting New Member

    how can they be used in live environment? how would the end user select if they want to use 5.3.x or 5.2.x...
  6. NiteWave

    NiteWave Administrator

  7. webhosting

    webhosting New Member

    I figured it out from the wiki, thanks a lot!
  8. webizen

    webizen New Member

    wiki has been updated with more detailed instructions.

Share This Page