[solved] error 503 after upgrade 4.2.1

Discussion in 'General' started by sicute, Feb 20, 2013.

  1. sicute

    sicute New Member

    hi ..

    i have problem with lsws standar 4.2.1 after upgrade my php not working , event i try php info only still get error 503 .

    My LSWS standar 4.2.1 with php 5.4.9 / 5.4.8 / 5.47.

    can i get clue ?
    Last edited by a moderator: Feb 20, 2013
  2. NiteWave

    NiteWave Administrator

    how about command line?

    #/usr/local/lsws/fcgi-bin/lsphp5 -i |head
  3. sicute

    sicute New Member

    solved .

    root@iix:/home/ison# /usr/local/lsws/fcgi-bin/lsphp-5.4.9 -v
    PHP Fatal error: Directive 'allow_call_time_pass_reference' is no longer available in PHP in Unknown on line 0

    edit php.ini in /usr/local/lsws/php/php.ini

    change
    allow_call_time_pass_reference = On

    #restrat
    root@iix:/home/ison# /etc/init.d/lsws restart
    root@iix:/home/ison#



    root@iix:/home/ison# /usr/local/lsws/fcgi-bin/lsphp-5.4.9 -v
    PHP 5.4.9 (litespeed) (built: Feb 19 2013 19:57:20)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
    root@iix:/home/ison#

    and everything back normal :)

    Thanks
  4. webizen

    webizen New Member

    the default php.ini (/usr/local/lsws/php/php.ini) shipped with LSWS may not be suiteable for the later PHP versions (5.4 in this case). hence the problem. use the php.ini (php.ini-production|development) that comes with php package should avoid this issue.

Share This Page