[Solved] How to install ioncube?

Discussion in 'Install/Configuration' started by teen9xpro, Nov 23, 2011.

  1. teen9xpro

    teen9xpro New Member

    Hi!

    I have a problem when I install Ioncube for my server.
    I download Ioncube-loader-wizard from ioncube.com and follow their instruction like this:

    But I can't install ioncube for my host.

    Plz help me!

    Regard!
  2. webizen

    webizen New Member

    you need put that "zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.3.so" in php.ini by lsphp5 (for lsws). to find out which php.ini in use, do:

  3. prandah

    prandah Member

    hello webizen
    i run this command
    but my result

    which one must copy file php.ini ?
  4. webizen

    webizen New Member

    do the following:

  5. andreig.

    andreig. New Member

    Hi, i have the same problem with IonCube.

    If i copy php.ini to /usr/lib64 incube is working but some sites will show white page.

    Any idea to resolv the problem ?
  6. webizen

    webizen New Member

    the php.ini copied over may have some default php settings (not incube related) changed which affects other sites (white page issue). you need to look at error log and see what those url/errors are.

    a possible workaround is only put the incube related line in the php.ini that is copied over (so other php settings are at default).
  7. andreig.

    andreig. New Member

    ok, i understand that

    i compiled php form litespeed web interface with

    how can i generate a new php.ini based on the new php configuration so i can add ioncube without affecting other site's with the blank page ?
  8. webizen

    webizen New Member

    you should leave everything default.

    iow, do

  9. andreig.

    andreig. New Member

    i know hot to put ioncube in php.ini but the problem is that i dont know where is php.ini generated from my last php compilation.

    in phpinfo i have
    i dont know what php.ini to copy in /usr/lib64 without affecting site-ul with a white page
  10. webizen

    webizen New Member

    if other sites are ok before (when no php.ini in /usr/lib64). iow, default php settings should be good for your other sites. you may create an empty php.ini in /usr/lib64. the result should be the same. then just add the line for ioncube like below.
    if other sites start to have problem (blank page) after that, then it is ioncube affects them.
  11. andreig.

    andreig. New Member

    yes, is working this way

    10x.

Share This Page