[Solved] Installing an SSL Certificate in WHM with LSWS

Discussion in 'General' started by dgtl, Feb 11, 2013.

  1. dgtl

    dgtl New Member

    Hello,

    When I try to install an SSL Certificate via WHM on a Litespeed powered server, the server automatically switched to from Litespeed to Apache. Is there a special set of instructions to avoid that? Especially when resellers can install SSL Certificates for their clients?

    Please advise
  2. webizen

    webizen New Member

    pls be more specific on how to reproduce the issue.
  3. dgtl

    dgtl New Member

    1. Login to WHM
    2. Navigate to " Install a SSL Certificate and Setup the Domain"
    3. Fill out the SSL Certificate information (Cert, Key, CA, Domain, IP, username etc...)
    4. Click "Submit"

    cPanel will proceed to install the SSL Certificate, and it will install it successfully. However, when I looked at Litespeed, it was off and Apache was on.

    Is this normal? Maybe I missed a step which tells cPanel to use lsws instead of httpd as it's default HTTP Server?
  4. webizen

    webizen New Member

  5. dgtl

    dgtl New Member

    This option was already selected. So I tried again, and the same issue happened. This server runs CENTOS 6.3 x86_64 xenpv / WHM 11.36.0 (build 6)

    Screenshot below:

    [​IMG]
  6. AdamMonroe

    AdamMonroe New Member

    Tried all of these methods but still I have the problem and after I tried to change the server goes offline.
  7. dgtl

    dgtl New Member

    Hello, any insight on this issue?
  8. webizen

    webizen New Member

    Please run below from command line and paste the screenshot here.

  9. dgtl

    dgtl New Member

    [​IMG]
    ^^ I think this is the key to the problem here.
  10. webizen

    webizen New Member

    use /usr/local/apache/bin/httpd instead of /usr/sbin/httpd.
  11. dgtl

    dgtl New Member

    Hello,

    Thanks! I made that change to LSWS Config and I can confirm that it has resolved the issue I had. Thank you very much!

Share This Page