[Solved] IP Address/~username not working

Discussion in 'General' started by openpotion, Jan 16, 2012.

  1. openpotion

    openpotion New Member

    If I turn on Apache I can reach my development sites at

    http://IPADDRESS/~username

    Then I can prep them prior to launch and pointing their dns away from their old site to their new one... without having to move it once it is ready.

    When I turn on Litespeed on my Knownhost VPS this no longer works.

    I need a workaround...

    My version info:
    Litespeed Web Server Enterprise v4.1.10

    Jason
  2. webizen

    webizen New Member

    for workaround, you can hardcode the IP in your localhost host file (/etc/hosts for *nix; C:\windows\system32\drivers\etc\hosts for windows). then send request (i.e. http://domain.com/) to the new site (served by lsws).

    to troubleshoot, look at the error log (i.e. /usr/local/apache/logs/error_log) when request http://IPADDRESS/~username
  3. openpotion

    openpotion New Member

    Hmm that workaround doesn't help since I have several employees at different locations working on sites. Is it possible for this to work?

    Knownhost provided the following:

    This is because the Apache's mod_userdir is allowing users to view their sites by entering a tilde(~) and their username as the uri on a specific host. This mod_userdir is not supported in Litespeed and you are not able to view the site in your server using the above temporarily link.

    True?
    Last edited: Jan 16, 2012
  4. webizen

    webizen New Member

    Litespeed supports mod_userdir. that's why need to troubleshoot and figure out where the problem is.

    the workaround (modify local hosts file) should work if you want to test the new site before switch DNS. Others (do not modify their local hosts file) will not be affected.
  5. openpotion

    openpotion New Member

    errors:

    The only relevant errors I can find:

    2012-01-16 11:59:29.480 [INFO] [HTAccess] Updating configuration from [/home/handytru/public_html/.htaccess]
    2012-01-16 11:59:30.583 [INFO] [67.60.143.36:38680-0#APVH_67.222.30.114_host.openpotion.com] File not found [/usr/local/apache/htdocs/templates/system/css/error.css]

    later this:
    2012-01-16 11:59:48.086 [NOTICE] [APVH_handytru_Suphp:] stop worker processes
    2012-01-16 11:59:51.482 [INFO] Remove pid: 15385, exitcode: 0

    Does this somehow help you?
  6. openpotion

    openpotion New Member

    Update... RewriteBase work?

    Looks like the rewritebase rule is being ignored...

    RewriteBase /~handytru

    this rule is required in order to run Joomla in a subdirectory.

    I disabled joomlas SEF URLs and can reach the page at http://host.openpotion.com/~handytru/
    however nearly every file mentioned is missing due to the relative URLs not starting at http://host.openpotion.com/~handytru/

    Notice /~handytru is missing in many URLs (screenshot): https://skitch.com/openpotion/g3gga/trucking-services-throughout-idaho-utah-and-beyond

    I think we are getting closer!
  7. openpotion

    openpotion New Member

    Got it! Joomla live_site configuration

    Okay... the livesite variable in the Joomla configuration file fixed the issue once I set it from null to http://host.openpotion.com/~handytru/

    SEF URLs now work...

    Cheers!

    Jason
  8. webizen

    webizen New Member

    thx for the update.

Share This Page