[solved] Litespeed is switching user id is .htaccess is present

Discussion in 'Bug Reports' started by Karl, Aug 29, 2012.

  1. Karl

    Karl New Member

    Hi,

    We have an odd issue, we have an account, that was moved from one drive to another, with a symlink in place from old location to new:

    /home/example -> /home2/example

    Folders:

    /home/example/public_html -> example.com
    /home/example/public_html/sub -> sub.example.com

    We have userdir enabled, so that: sub.example.com/~example would load content from:

    /home/example/public_html

    (don't ask)

    Now this all works fine, and a PHP script getting the posix_userid() returns the correct user ID.

    Now if we place a .htaccess file in:

    /home/example/public_html

    when accessing a script via:

    sub.example.com/~example/script.php

    it outputs 99 - the nobody user. If we remove the .htaccess from /home/example/public_html then the self same script gives the correct userid for the example user.

    Any help much appreciated, this seems a bit of a bug. The .htaccess is empty, nothing in it at all. All files and directories have the correct example user ownership.

    Thanks,
    Last edited by a moderator: Sep 6, 2012
  2. mistwang

    mistwang LiteSpeed Staff

    It is not something can be easily reproduced in our lab.
    Can you please enable debug logging , run one test with .htaccess present, one without, send the section of related log file to bug@litespeed...
  3. mistwang

    mistwang LiteSpeed Staff

    make sure you are using the latest 4.1.13 release, do a force reinstall before running the test.
  4. Karl

    Karl New Member

    Hi,

    It's on 4.1.13 and we've already tried a force re-install. Will test with debug logging enabled.

    Thanks,
  5. Karl

    Karl New Member

    So where do I send these logs?

    I've got it with and without the .htaccess file present. I can't see anything myself in them that doesn't look right.

    I don't fancy posting them here, as they obviously have quite a lot of sensitive info in them.

    Thanks,
  6. webizen

    webizen New Member

    you can pm or email to bug@
  7. Karl

    Karl New Member

    Hi,

    Sent to bug@ about an hour or so ago.

    Thanks,
  8. mistwang

    mistwang LiteSpeed Staff

    this issue has been addressed in the latest 4.1.13 build.
  9. Karl

    Karl New Member

    ...and it works like a charm, thanks.

Share This Page