[Solved] Litespeed not reading .htaccess file

Discussion in 'General' started by optize, Jun 29, 2012.

  1. optize

    optize New Member

    cPanel uses the following alias:

    Alias /bandwidth /usr/local/bandmin/htdocs/

    /usr/local/bandmin/htdocs/.htaccess has a username/password auth

    However, it's not reading it, here is the Directory listing that would apply to that directory:

    <Directory "/">
    Options ExecCGI IncludesNOEXEC Indexes SymLinksIfOwnerMatch
    AllowOverride All
    </Directory>

    My apache servers which the same config work fine, so kinda odd.

    Does Litespeed NOT read .htaccess files in this directory for some reason?
  2. optize

    optize New Member

    It looks like it's related to the virtualhost, not path.

    Anything over the main server domain isn't being read by .htaccess.

    Thoughts?
  3. webizen

    webizen New Member

    check their ownership and permission
  4. optize

    optize New Member

    drwxr-xr-x 2 root wheel 4096 Nov 21 2011 /usr/local/bandmin/htdocs/
    -rw-r--r-- 1 root root 93 Dec 23 2010 /usr/local/bandmin/htdocs/.htaccess
  5. webizen

    webizen New Member

    Can you elaborate this?
  6. optize

    optize New Member

  7. webizen

    webizen New Member

    What about HTAccess (Admin Console => Configuration => Server => General)? Make sure everything is checked except for None.
  8. optize

    optize New Member

    Correct, htaccess files are working for other domains.
  9. webizen

    webizen New Member

    tested in our lab:

    1. subdomain (blah1.server.com) is ok. password promoted
    2. alias (blah1.server.com/bandmin) is ok. password prompted.

    you can enable debug logging (Admin Console => Configuration => Log => Log Level: DEBUG; Debug Level: Low)

    if working, it should show something like 401 unauthorized as shown below:

  10. optize

    optize New Member

    2012-07-02 09:44:35.856 [DEBUG] [x.x.x.x:39055-0#APVH_199.96.x.x_cp21.xxx.com] [REWRITE] Rewrite engine is not enabled for context '/'
  11. optize

    optize New Member

    Er, that error is normal... Mine shows nothing about an .htaccess when visiting /bandwidth
  12. webizen

    webizen New Member

    you meant /bandmin? pm temporary ssh root access if you like us look further.
  13. webizen

    webizen New Member

    pls try the latest 4.1.13.
  14. optize

    optize New Member

    Fixed.... Thanks

Share This Page